Command injection in ng-packagr
Priority LOW 34CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
The package ng-packagr before 10.1.1 are vulnerable to Command Injection via the styleIncludePaths option.
Why it matters now
EPSS 0.0239 84th percentileScored 2026-11-07
Fix Fixed ng-packagr: 10.1.1ng-packagr (npm): 10.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ng-packagr | before 10.1.1 | 10.1.1 | Patch available | CNA |
| — | ng-packagr (npm) | before 10.1.1 | 10.1.1 | Patch available | GHSA-qm28-7hqv-wg5j |
- ng-packagr Vendor— Affected before 10.1.1 Fixed in 10.1.1 Patch available CNA
- ng-packagr (npm) Vendor— Affected before 10.1.1 Fixed in 10.1.1 Patch available GHSA-qm28-7hqv-wg5j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ng-packagr_project:ng-packagr:*:*:*:*:*:*:*:* | before 10.1.1 | Vulnerable | Ng-packagr Project |
- cpe:2.3:a:ng-packagr_project:ng-packagr:*:*:*:*:*:*:*:* Versions before 10.1.1 Vulnerable ·Ng-packagr Project
Remediation
- Fix · CNA ng-packagr Fixed in 10.1.1
- Fix · GHSA-qm28-7hqv-wg5j ng-packagr (npm) Fixed in 10.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7735
- 2026-10-03 Alias added: GHSA-qm28-7hqv-wg5j
References
Sources
- CVE-2020-7735 · CVE Program
- CVE-2020-7735 · NVD
- FIRST EPSS
- GHSA-qm28-7hqv-wg5j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences