Command injection in node-notifier
Priority LOW 28CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Partial Red Hat: 2 fixed, 4 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.
Summary
This affects the package node-notifier before 9.0.0. It allows an attacker to run arbitrary commands on Linux machines due to the options params not being sanitised when being passed an array.
Why it matters now
EPSS 0.01587 75th percentileScored 2026-11-07
Fix Partial node-notifier: 9.0.0node-notifier (npm): 8.0.1Red Hat: 1 advisoryRed Hat: 2 fixed, 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | node-notifier | before 9.0.0 | 9.0.0 | Patch available | CNA |
| — | node-notifier (npm) | before 8.0.1 | 8.0.1 | Patch available | GHSA-5fw9-fq32-wv5p |
- node-notifier Vendor— Affected before 9.0.0 Fixed in 9.0.0 Patch available CNA
- node-notifier (npm) Vendor— Affected before 8.0.1 Fixed in 8.0.1 Patch available GHSA-5fw9-fq32-wv5p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:node-notifier_project:node-notifier:*:*:*:*:*:node.js:*:* | before 8.0.1 | Vulnerable | Node-notifier Project |
- cpe:2.3:a:node-notifier_project:node-notifier:*:*:*:*:*:node.js:*:* Versions before 8.0.1 Vulnerable ·Node-notifier Project
Remediation
- Fix · CNA node-notifier Fixed in 9.0.0
- Fix · GHSA-5fw9-fq32-wv5p node-notifier (npm) Fixed in 8.0.1 Advisory →
Red Hat 1 advisory
- RHSA-2021:0781 Released 2021-03-09 · Red Hat rating ModerateRed Hat Ansible Automation Platform 1.2.2 security and bug fix update
- Red Hat Automation Hub 4.2 for RHEL 7 automation-hub-4.2.2-1.el7pc, python-bleach-3.3.0-1.el7pc, python-bleach-allowlist-1.0.3-1.el7pc +9
- Red Hat Automation Hub 4.2 for RHEL 8 automation-hub-4.2.2-1.el8pc, python-bleach-3.3.0-1.el8pc, python-bleach-allowlist-1.0.3-1.el8pc +9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 1 | Affected | No fix planned: Out of support scope |
| OpenShift Service Mesh 2.0 | Affected | No fix planned: Will not fix |
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix planned: Out of support scope |
| Red Hat OpenShift Container Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Automation Hub 4.2 for RHEL 7 | Fixed | RHSA-2021:0781 |
| Red Hat Automation Hub 4.2 for RHEL 8 | Fixed | RHSA-2021:0781 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-7789
- 2026-10-03 Alias added: GHSA-5fw9-fq32-wv5p
References
Sources
- CVE-2020-7789 · CVE Program
- CVE-2020-7789 · NVD
- FIRST EPSS
- GHSA-5fw9-fq32-wv5p · GitHub Advisory Database · CC BY 4.0
- CVE-2020-7789 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences