race condition in the packaging of texlive-filesysten
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A Race Condition Enabling Link Following vulnerability in the packaging of texlive-filesystem of SUSE Linux Enterprise Module for Desktop Applications 15-SP1, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP5; openSUSE Leap 15.1 allows local users to corrupt files or potentially escalate privileges. This issue affects: SUSE Linux Enterprise Module for Desktop Applications 15-SP1 texlive-filesystem versions prior to 2017.135-9.5.1. SUSE Linux Enterprise Software Development Kit 12-SP4 texlive-filesystem versions prior to 2013.74-16.5.1. SUSE Linux Enterprise Software Development Kit 12-SP5 texlive-filesystem versions prior to 2013.74-16.5.1. openSUSE Leap 15.1 texlive-filesystem versions prior to 2017.135-lp151.8.3.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Module for Desktop Applications 15-SP1 | texlive-filesystem to before 2017.135-9.5.1 | 2017.135-9.5.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Software Development Kit 12-SP4 | texlive-filesystem to before 2013.74-16.5.1 | 2013.74-16.5.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Software Development Kit 12-SP5 | texlive-filesystem to before 2013.74-16.5.1 | 2013.74-16.5.1 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.1 | texlive-filesystem to before 2017.135-lp151.8.3.1 | 2017.135-lp151.8.3.1 | Patch available | CNA |
- SUSE Linux Enterprise Module for Desktop Applications 15-SP1 VendorSUSE Affected texlive-filesystem to before 2017.135-9.5.1 Fixed in 2017.135-9.5.1 Patch available CNA
- SUSE Linux Enterprise Software Development Kit 12-SP4 VendorSUSE Affected texlive-filesystem to before 2013.74-16.5.1 Fixed in 2013.74-16.5.1 Patch available CNA
- SUSE Linux Enterprise Software Development Kit 12-SP5 VendorSUSE Affected texlive-filesystem to before 2013.74-16.5.1 Fixed in 2013.74-16.5.1 Patch available CNA
- openSUSE Leap 15.1 VendoropenSUSE Affected texlive-filesystem to before 2017.135-lp151.8.3.1 Fixed in 2017.135-lp151.8.3.1 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensuse:texlive-filesystem:*:*:*:*:*:*:*:* | before 2017.135-9.5.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_desktop:15:sp1:*:*:*:*:*:* | 15 sp1 | Running on | SUSE |
| cpe:2.3:a:opensuse:texlive-filesystem:*:*:*:*:*:*:*:* | before 2013.74-16.5.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp4:*:*:*:*:*:* | 12 sp4 | Running on | SUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp5:*:*:*:*:*:* | 12 sp5 | Running on | SUSE |
| cpe:2.3:a:opensuse:texlive-filesystem:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_desktop:15:-:*:*:*:*:*:* | 15 | Running on | SUSE |
| cpe:2.3:a:opensuse:texlive-filesystem:*:*:*:*:*:*:*:* | before 2017.135-lp151.8.3.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Running on | openSUSE |
- cpe:2.3:a:opensuse:texlive-filesystem:*:*:*:*:*:*:*:* Versions before 2017.135-9.5.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_desktop:15:sp1:*:*:*:*:*:* Versions 15 sp1 Running on ·SUSE
- cpe:2.3:a:opensuse:texlive-filesystem:*:*:*:*:*:*:*:* Versions before 2013.74-16.5.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp4:*:*:*:*:*:* Versions 12 sp4 Running on ·SUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp5:*:*:*:*:*:* Versions 12 sp5 Running on ·SUSE
- cpe:2.3:a:opensuse:texlive-filesystem:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_desktop:15:-:*:*:*:*:*:* Versions 15 Running on ·SUSE
- cpe:2.3:a:opensuse:texlive-filesystem:*:*:*:*:*:*:*:* Versions before 2017.135-lp151.8.3.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Running on ·openSUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (SUSE) Fixed in 2017.135-9.5.1
- Fix · CNA SUSE Linux Enterprise Software Development Kit 12-SP4 (SUSE) Fixed in 2013.74-16.5.1
- Fix · CNA SUSE Linux Enterprise Software Development Kit 12-SP5 (SUSE) Fixed in 2013.74-16.5.1
- Fix · CNA openSUSE Leap 15.1 (openSUSE) Fixed in 2017.135-lp151.8.3.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
SUSE Linux Enterprise Module for Desktop Applications 15-SP1, SUSE Linux Enterprise Software Development Kit 12-SP4 and 2 more products — openSUSE-SU-2020:0804
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2020-06487 race condition on texlive-filesystem cron job allows for the deletion of unintended filesPriority LOW 27
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8016
- 2026-10-03 Alias added: GHSA-gw5h-q2x4-wff3
References
Advisory 1
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-8016 · CVE Program
- CVE-2020-8016 · NVD
- FIRST EPSS
- GHSA-gw5h-q2x4-wff3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences