Problematic permissions in hylafax+ packaging allow escalation from uucp to other users
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
A Incorrect Default Permissions vulnerability in the packaging of hylafax+ of openSUSE Leap 15.2, openSUSE Leap 15.1, openSUSE Factory allows local attackers to escalate from user uucp to users calling hylafax binaries. This issue affects: openSUSE Leap 15.2 hylafax+ versions prior to 7.0.2-lp152.2.1. openSUSE Leap 15.1 hylafax+ version 5.6.1-lp151.3.7 and prior versions. openSUSE Factory hylafax+ versions prior to 7.0.2-2.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openSUSE | openSUSE Leap 15.2 | hylafax+ to before 7.0.2-lp152.2.1 | 7.0.2-lp152.2.1 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.1 | hylafax+ – 5.6.1-lp151.3.7 | — | No fix listed | CNA |
| openSUSE | openSUSE Factory | hylafax+ to before 7.0.2-2.1 | 7.0.2-2.1 | Patch available | CNA |
- openSUSE Leap 15.2 VendoropenSUSE Affected hylafax+ to before 7.0.2-lp152.2.1 Fixed in 7.0.2-lp152.2.1 Patch available CNA
- openSUSE Leap 15.1 VendoropenSUSE Affected hylafax+ – 5.6.1-lp151.3.7 Fixed in — No fix listed CNA
- openSUSE Factory VendoropenSUSE Affected hylafax+ to before 7.0.2-2.1 Fixed in 7.0.2-2.1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensuse:hylafax\+:*:*:*:*:*:*:*:* | before 7.0.2-lp152.2.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Running on | openSUSE |
| cpe:2.3:a:opensuse:hylafax\+:*:*:*:*:*:*:*:* | before 5.6.1-lp151.3.7 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Running on | openSUSE |
| cpe:2.3:a:opensuse:hylafax\+:*:*:*:*:*:*:*:* | before 7.0.2-2.1 | Vulnerable | openSUSE |
- cpe:2.3:a:opensuse:hylafax\+:*:*:*:*:*:*:*:* Versions before 7.0.2-lp152.2.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Running on ·openSUSE
- cpe:2.3:a:opensuse:hylafax\+:*:*:*:*:*:*:*:* Versions before 5.6.1-lp151.3.7 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Running on ·openSUSE
- cpe:2.3:a:opensuse:hylafax\+:*:*:*:*:*:*:*:* Versions before 7.0.2-2.1 Vulnerable ·openSUSE
Remediation
- Fix · CNA openSUSE Leap 15.2 (openSUSE) Fixed in 7.0.2-lp152.2.1
- Fix · CNA openSUSE Factory (openSUSE) Fixed in 7.0.2-2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8024
- 2026-10-03 Alias added: GHSA-rv88-x9wr-52g7
References
Sources
- CVE-2020-8024 · CVE Program
- CVE-2020-8024 · NVD
- FIRST EPSS
- GHSA-rv88-x9wr-52g7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences