outdated entries in permissions profiles for /var/lib/pcp/tmp/* may cause security issues
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A Incorrect Execution-Assigned Permissions vulnerability in the permissions package of SUSE Linux Enterprise Server 12-SP4, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15; openSUSE Leap 15.1, openSUSE Tumbleweed sets the permissions for some of the directories of the pcp package to unintended settings. This issue affects: SUSE Linux Enterprise Server 12-SP4 permissions versions prior to 20170707-3.24.1. SUSE Linux Enterprise Server 15-LTSS permissions versions prior to 20180125-3.27.1. SUSE Linux Enterprise Server for SAP 15 permissions versions prior to 20180125-3.27.1. openSUSE Leap 15.1 permissions versions prior to 20181116-lp151.4.24.1. openSUSE Tumbleweed permissions versions prior to 20200624.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server 12-SP4 | permissions to before 20170707-3.24.1 | 20170707-3.24.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Server 15-LTSS | permissions to before 20180125-3.27.1 | 20180125-3.27.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Server for SAP 15 | permissions to before 20180125-3.27.1 | 20180125-3.27.1 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.1 | permissions to before 20181116-lp151.4.24.1 | 20181116-lp151.4.24.1 | Patch available | CNA |
| openSUSE | openSUSE Tumbleweed | permissions to before 20200624 | 20200624 | Patch available | CNA |
- SUSE Linux Enterprise Server 12-SP4 VendorSUSE Affected permissions to before 20170707-3.24.1 Fixed in 20170707-3.24.1 Patch available CNA
- SUSE Linux Enterprise Server 15-LTSS VendorSUSE Affected permissions to before 20180125-3.27.1 Fixed in 20180125-3.27.1 Patch available CNA
- SUSE Linux Enterprise Server for SAP 15 VendorSUSE Affected permissions to before 20180125-3.27.1 Fixed in 20180125-3.27.1 Patch available CNA
- openSUSE Leap 15.1 VendoropenSUSE Affected permissions to before 20181116-lp151.4.24.1 Fixed in 20181116-lp151.4.24.1 Patch available CNA
- openSUSE Tumbleweed VendoropenSUSE Affected permissions to before 20200624 Fixed in 20200624 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:suse:linux_enterprise_high_performance_computing:15:*:*:*:espos:*:*:* | 15 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_high_performance_computing:15:*:*:*:ltss:*:*:* | 15 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:ltss:*:*:* | 15 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_server:15:sp1:*:*:*:*:*:* | 15 sp1 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_server:15:sp2:*:*:*:*:*:* | 15 sp2 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp4:*:*:*:*:*:* | 12 sp4 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp5:*:*:*:*:*:* | 12 sp5 | Vulnerable | SUSE |
- cpe:2.3:o:suse:linux_enterprise_high_performance_computing:15:*:*:*:espos:*:*:* Versions 15 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_high_performance_computing:15:*:*:*:ltss:*:*:* Versions 15 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:ltss:*:*:* Versions 15 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_server:15:sp1:*:*:*:*:*:* Versions 15 sp1 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_server:15:sp2:*:*:*:*:*:* Versions 15 sp2 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp4:*:*:*:*:*:* Versions 12 sp4 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp5:*:*:*:*:*:* Versions 12 sp5 Vulnerable ·SUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Server 12-SP4 (SUSE) Fixed in 20170707-3.24.1
- Fix · CNA SUSE Linux Enterprise Server 15-LTSS (SUSE) Fixed in 20180125-3.27.1
- Fix · CNA SUSE Linux Enterprise Server for SAP 15 (SUSE) Fixed in 20180125-3.27.1
- Fix · CNA openSUSE Leap 15.1 (openSUSE) Fixed in 20181116-lp151.4.24.1
- Fix · CNA openSUSE Tumbleweed (openSUSE) Fixed in 20200624
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8025
- 2026-10-03 Alias added: GHSA-g55h-q572-52j6
References
More SUSE Linux Enterprise High Performance Computing vulnerabilities
- TI-2026-23989 crypto: algif_aead - Revert to operating out-of-place KEVCVSS 3.1HIGH 7.8
- TI-2021-02923 Out-of-bounds write in polkit KEVCVSS 3.1HIGH 7.8
- TI-2024-31348 An issue was discovered in psi/zfile.c in Artifex Ghostscript before 10.04.0. CVSS 3.1HIGH 7.8
- TI-2024-31345 An issue was discovered in base/gsdevice.c in Artifex Ghostscript before 10.04.0. CVSS 3.1HIGH 7.8
- TI-2024-31343 An issue was discovered in psi/zcolor.c in Artifex Ghostscript before 10.04.0. CVSS 3.1HIGH 7.8
- TI-2022-10358 In cifs-utils through 6.14, a stack-based buffer overflow when parsing the mount.cifs ip=… CVSS 3.1HIGH 7.8
Sources
- CVE-2020-8025 · CVE Program
- CVE-2020-8025 · NVD
- FIRST EPSS
- GHSA-g55h-q572-52j6 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-8025 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences