openldap uses fixed paths in /tmp
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
A Insecure Temporary File vulnerability in openldap2 of SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise Server for SAP 15; openSUSE Leap 15.1, openSUSE Leap 15.2 allows local attackers to overwrite arbitrary files and gain access to the openldap2 configuration This issue affects: SUSE Linux Enterprise Server 15-LTSS openldap2 versions prior to 2.4.46-9.37.1. SUSE Linux Enterprise Server for SAP 15 openldap2 versions prior to 2.4.46-9.37.1. openSUSE Leap 15.1 openldap2 versions prior to 2.4.46-lp151.10.18.1. openSUSE Leap 15.2 openldap2 versions prior to 2.4.46-lp152.14.9.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server 15-LTSS | openldap2 to before 2.4.46-9.37.1 | 2.4.46-9.37.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Server for SAP 15 | openldap2 to before 2.4.46-9.37.1 | 2.4.46-9.37.1 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.1 | openldap2 to before 2.4.46-lp151.10.18.1 | 2.4.46-lp151.10.18.1 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.2 | openldap2 to before 2.4.46-lp152.14.9.1 | 2.4.46-lp152.14.9.1 | Patch available | CNA |
- SUSE Linux Enterprise Server 15-LTSS VendorSUSE Affected openldap2 to before 2.4.46-9.37.1 Fixed in 2.4.46-9.37.1 Patch available CNA
- SUSE Linux Enterprise Server for SAP 15 VendorSUSE Affected openldap2 to before 2.4.46-9.37.1 Fixed in 2.4.46-9.37.1 Patch available CNA
- openSUSE Leap 15.1 VendoropenSUSE Affected openldap2 to before 2.4.46-lp151.10.18.1 Fixed in 2.4.46-lp151.10.18.1 Patch available CNA
- openSUSE Leap 15.2 VendoropenSUSE Affected openldap2 to before 2.4.46-lp152.14.9.1 Fixed in 2.4.46-lp152.14.9.1 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensuse:openldap2:*:*:*:*:*:*:*:* | before 2.4.46-9.37.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:ltss:*:*:* | 15 | Running on | SUSE |
| cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:*:sap:*:* | 15 | Running on | SUSE |
| cpe:2.3:a:opensuse:openldap2:*:*:*:*:*:*:*:* | before 2.4.46-lp151.10.18.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Running on | openSUSE |
| cpe:2.3:a:opensuse:openldap2:*:*:*:*:*:*:*:* | before 2.4.46-lp152.14.9.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Running on | openSUSE |
- cpe:2.3:a:opensuse:openldap2:*:*:*:*:*:*:*:* Versions before 2.4.46-9.37.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:ltss:*:*:* Versions 15 Running on ·SUSE
- cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:*:sap:*:* Versions 15 Running on ·SUSE
- cpe:2.3:a:opensuse:openldap2:*:*:*:*:*:*:*:* Versions before 2.4.46-lp151.10.18.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Running on ·openSUSE
- cpe:2.3:a:opensuse:openldap2:*:*:*:*:*:*:*:* Versions before 2.4.46-lp152.14.9.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Running on ·openSUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Server 15-LTSS (SUSE) Fixed in 2.4.46-9.37.1
- Fix · CNA SUSE Linux Enterprise Server for SAP 15 (SUSE) Fixed in 2.4.46-9.37.1
- Fix · CNA openSUSE Leap 15.1 (openSUSE) Fixed in 2.4.46-lp151.10.18.1
- Fix · CNA openSUSE Leap 15.2 (openSUSE) Fixed in 2.4.46-lp152.14.9.1
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8027
- 2026-10-03 Alias added: GHSA-9rfj-vjc2-f7cj
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-8027 · CVE Program
- CVE-2020-8027 · NVD
- FIRST EPSS
- GHSA-9rfj-vjc2-f7cj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences