Improper input validation in klona npm module
Priority MEDIUM 49CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Flaw in input validation in npm package klona version 1.1.0 and earlier may allow prototype pollution attack that may result in remote code execution or denial of service of applications using klona.
Why it matters now
EPSS 0.04118 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed klona (npm): 1.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | klona npm module | Fixed Version: v1.1.1 | — | No fix listed | CNA |
| — | klona (npm) | before 1.1.1 | 1.1.1 | Patch available | GHSA-8f89-2fwj-5v5r |
- klona npm module Vendor— Affected Fixed Version: v1.1.1 Fixed in — No fix listed CNA
- klona (npm) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-8f89-2fwj-5v5r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:klona_project:klona:*:*:*:*:*:node.js:*:* | up to 1.1.0 | Vulnerable | Klona Project |
- cpe:2.3:a:klona_project:klona:*:*:*:*:*:node.js:*:* Versions up to 1.1.0 Vulnerable ·Klona Project
Remediation
- Fix · GHSA-8f89-2fwj-5v5r klona (npm) Fixed in 1.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8125
- 2026-10-03 Alias added: GHSA-8f89-2fwj-5v5r
References
Sources
- CVE-2020-8125 · CVE Program
- CVE-2020-8125 · NVD
- FIRST EPSS
- GHSA-8f89-2fwj-5v5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences