Code injection in script-manager
Priority MEDIUM 47CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
An unintended require vulnerability in script-manager npm package version 0.8.6 and earlier may allow attackers to execute arbitrary code.
Why it matters now
EPSS 0.02943 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed script-manager (npm): 0.9.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | script-manager | Fixed version: 0.9.0 | — | No fix listed | CNA |
| — | script-manager (npm) | before 0.9.0 | 0.9.0 | Patch available | GHSA-rhwf-hqpr-q8g2 |
- script-manager Vendor— Affected Fixed version: 0.9.0 Fixed in — No fix listed CNA
- script-manager (npm) Vendor— Affected before 0.9.0 Fixed in 0.9.0 Patch available GHSA-rhwf-hqpr-q8g2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:script-manager_project:script-manager:*:*:*:*:*:node.js:*:* | up to 0.8.6 | Vulnerable | Script-manager Project |
- cpe:2.3:a:script-manager_project:script-manager:*:*:*:*:*:node.js:*:* Versions up to 0.8.6 Vulnerable ·Script-manager Project
Remediation
- Fix · GHSA-rhwf-hqpr-q8g2 script-manager (npm) Fixed in 0.9.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8129
- 2026-10-03 Alias added: GHSA-rhwf-hqpr-q8g2
References
Sources
- CVE-2020-8129 · CVE Program
- CVE-2020-8129 · NVD
- FIRST EPSS
- GHSA-rhwf-hqpr-q8g2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences