Code injection in logkitty
Priority MEDIUM 46CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Lack of output sanitization allowed an attack to execute arbitrary shell commands via the logkitty npm package before version 0.7.1.
Why it matters now
EPSS 0.0201 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed logkitty (npm): 0.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | logkitty | Fixed Version: 0.7.1 | — | No fix listed | CNA |
| — | logkitty (npm) | before 0.7.1 | 0.7.1 | Patch available | GHSA-v8v8-6859-qxm4 |
- logkitty Vendor— Affected Fixed Version: 0.7.1 Fixed in — No fix listed CNA
- logkitty (npm) Vendor— Affected before 0.7.1 Fixed in 0.7.1 Patch available GHSA-v8v8-6859-qxm4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:logkitty_project:logkitty:*:*:*:*:*:*:*:* | before 0.7.1 | Vulnerable | Logkitty Project |
- cpe:2.3:a:logkitty_project:logkitty:*:*:*:*:*:*:*:* Versions before 0.7.1 Vulnerable ·Logkitty Project
Remediation
- Fix · GHSA-v8v8-6859-qxm4 logkitty (npm) Fixed in 0.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8149
- 2026-10-03 Alias added: GHSA-v8v8-6859-qxm4
References
Sources
- CVE-2020-8149 · CVE Program
- CVE-2020-8149 · NVD
- FIRST EPSS
- GHSA-v8v8-6859-qxm4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences