Deserialization of untrusted data in https://github.com/rails/rails
Priority MEDIUM 41CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.
Summary
A deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker to supply information can be inadvertently leaked fromStrong Parameters.
Why it matters now
EPSS 0.04889 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial actionpack (RubyGems): 5.2.4.3, 6.0.3.1Red Hat: 1 advisoryRed Hat: 2 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/rails/rails | 5.2.4.3, 6.0.3.1 | — | No fix listed | CNA |
| — | actionpack (RubyGems) | 5.0.0 to before 5.2.4.3 | 5.2.4.3 | Patch available | GHSA-8727-m6gj-mc37 |
| — | actionpack (RubyGems) | 6.0.0 to before 6.0.3.1 | 6.0.3.1 | Patch available | GHSA-8727-m6gj-mc37 |
- https://github.com/rails/rails Vendor— Affected 5.2.4.3, 6.0.3.1 Fixed in — No fix listed CNA
- actionpack (RubyGems) Vendor— Affected 5.0.0 to before 5.2.4.3 Fixed in 5.2.4.3 Patch available GHSA-8727-m6gj-mc37
- actionpack (RubyGems) Vendor— Affected 6.0.0 to before 6.0.3.1 Fixed in 6.0.3.1 Patch available GHSA-8727-m6gj-mc37
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* | before 5.2.4.3; 6.0.0 to before 6.0.3.1 | Vulnerable | Rails |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Vulnerable | openSUSE |
- cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* Versions before 5.2.4.3; 6.0.0 to before 6.0.3.1 Vulnerable ·Rails
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-8727-m6gj-mc37 actionpack (RubyGems) Fixed in 5.2.4.3 Advisory →
- Fix · GHSA-8727-m6gj-mc37 actionpack (RubyGems) Fixed in 6.0.3.1 Advisory →
Red Hat 1 advisory
- RHSA-2021:1313 Released 2021-04-21 · Red Hat rating ModerateSatellite 6.9 Release
- Red Hat Satellite 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
- Red Hat Satellite Capsule 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.9 | Fixed | RHSA-2021:1313 |
| Red Hat Satellite Capsule 6.9 | Fixed | RHSA-2021:1313 |
Not affected: 1 product
- CloudForms Management Engine 5
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8164
- 2026-10-03 Alias added: GHSA-8727-m6gj-mc37
References
Exploit 1
Advisory 7
Sources
- CVE-2020-8164 · CVE Program
- CVE-2020-8164 · NVD
- FIRST EPSS
- GHSA-8727-m6gj-mc37 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-8164 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences