Deserialization of untrusted data in https://github.com/rails/rails
Priority HIGH 72CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-502.
Summary
A deserialization of untrusted data vulnernerability exists in rails < 5.2.4.3, rails < 6.0.3.1 that can allow an attacker to unmarshal user-provided objects in MemCacheStore and RedisCacheStore potentially resulting in an RCE.
Why it matters now
EPSS 0.45732 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial activesupport (RubyGems): 5.2.4.3, 6.0.3.1Red Hat: 1 advisoryRed Hat: 2 fixed, 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/rails/rails | Fixed in 5.2.4.3, 6.0.3.1 | — | No fix listed | CNA |
| — | activesupport (RubyGems) | 5.0.0 to before 5.2.4.3 | 5.2.4.3 | Patch available | GHSA-2p68-f74v-9wc6 |
| — | activesupport (RubyGems) | 6.0.0 to before 6.0.3.1 | 6.0.3.1 | Patch available | GHSA-2p68-f74v-9wc6 |
- https://github.com/rails/rails Vendor— Affected Fixed in 5.2.4.3, 6.0.3.1 Fixed in — No fix listed CNA
- activesupport (RubyGems) Vendor— Affected 5.0.0 to before 5.2.4.3 Fixed in 5.2.4.3 Patch available GHSA-2p68-f74v-9wc6
- activesupport (RubyGems) Vendor— Affected 6.0.0 to before 6.0.3.1 Fixed in 6.0.3.1 Patch available GHSA-2p68-f74v-9wc6
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* | before 5.2.4.3; 6.0.0 to before 6.0.3.1 | Vulnerable | Rails |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Vulnerable | openSUSE |
- cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* Versions before 5.2.4.3; 6.0.0 to before 6.0.3.1 Vulnerable ·Rails
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-2p68-f74v-9wc6 activesupport (RubyGems) Fixed in 5.2.4.3 Advisory →
- Fix · GHSA-2p68-f74v-9wc6 activesupport (RubyGems) Fixed in 6.0.3.1 Advisory →
Red Hat 1 advisory
- RHSA-2021:1313 Released 2021-04-21 · Red Hat rating ModerateSatellite 6.9 Release
- Red Hat Satellite 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
- Red Hat Satellite Capsule 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix yet: Fix deferred |
| Red Hat Storage 3 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6.9 | Fixed | RHSA-2021:1313 |
| Red Hat Satellite Capsule 6.9 | Fixed | RHSA-2021:1313 |
Not affected: 2 products
- CloudForms Management Engine 5
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8165
- 2026-10-03 Alias added: GHSA-2p68-f74v-9wc6
References
Exploit 1
Advisory 7
- [debian-lts-announce] 20200619 [SECURITY] [DLA 2251-1] rails security update
- https://weblog.rubyonrails.org/2020/5/18/Rails-5-2-4-3-and-6-0-3-1-have-been-released/
- [debian-lts-announce] 20200720 [SECURITY] [DLA 2282-1] rails security update
- DSA-4766
- openSUSE-SU-2020:1677
- openSUSE-SU-2020:1679
- https://nvd.nist.gov/vuln/detail/CVE-2020-8165
Other 4
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activesupport/CVE-2020-8165.yml
- https://groups.google.com/forum/#!topic/rubyonrails-security/bv6fW4S0Y1c
- https://security.netapp.com/advisory/ntap-20250509-0002
- https://weblog.rubyonrails.org/2020/5/18/Rails-5-2-4-3-and-6-0-3-1-have-been-released
Sources
- CVE-2020-8165 · CVE Program
- CVE-2020-8165 · NVD
- FIRST EPSS
- GHSA-2p68-f74v-9wc6 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-8165 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences