Cross-site request forgery in https://github.com/rails/rails
Priority MEDIUM 53CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-352.
Summary
A CSRF forgery vulnerability exists in rails < 5.2.5, rails < 6.0.4 that makes it possible for an attacker to, given a global CSRF token such as the one present in the authenticity_token meta tag, forge a per-form CSRF token.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01673 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial actionpack (RubyGems): 5.2.4.3, 6.0.3.1Red Hat: 1 advisoryRed Hat: 2 fixed, 1 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/rails/rails | Fixed in 5.2.4.3, 6.0.3.1 | — | No fix listed | CNA |
| — | actionpack (RubyGems) | 5.0.0 to before 5.2.4.3 | 5.2.4.3 | Patch available | GHSA-jp5v-5gx4-jmj9 |
| — | actionpack (RubyGems) | 6.0.0 to before 6.0.3.1 | 6.0.3.1 | Patch available | GHSA-jp5v-5gx4-jmj9 |
- https://github.com/rails/rails Vendor— Affected Fixed in 5.2.4.3, 6.0.3.1 Fixed in — No fix listed CNA
- actionpack (RubyGems) Vendor— Affected 5.0.0 to before 5.2.4.3 Fixed in 5.2.4.3 Patch available GHSA-jp5v-5gx4-jmj9
- actionpack (RubyGems) Vendor— Affected 6.0.0 to before 6.0.3.1 Fixed in 6.0.3.1 Patch available GHSA-jp5v-5gx4-jmj9
Remediation
- Fix · GHSA-jp5v-5gx4-jmj9 actionpack (RubyGems) Fixed in 5.2.4.3 Advisory →
- Fix · GHSA-jp5v-5gx4-jmj9 actionpack (RubyGems) Fixed in 6.0.3.1 Advisory →
Red Hat 1 advisory
- RHSA-2021:1313 Released 2021-04-21 · Red Hat rating ModerateSatellite 6.9 Release
- Red Hat Satellite 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
- Red Hat Satellite Capsule 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.9 | Fixed | RHSA-2021:1313 |
| Red Hat Satellite Capsule 6.9 | Fixed | RHSA-2021:1313 |
Not affected: 1 product
- CloudForms Management Engine 5
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8166
- 2026-10-03 Alias added: GHSA-jp5v-5gx4-jmj9
References
Exploit 1
Sources
- CVE-2020-8166 · CVE Program
- CVE-2020-8166 · NVD
- FIRST EPSS
- GHSA-jp5v-5gx4-jmj9 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-8166 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences