Cross-site scripting in koa-shopify-auth
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability exists in koa-shopify-auth v3.1.61-v3.1.62 that allows an attacker to inject JS payloads into the `shop` parameter on the `/shopify/auth/enable_cookies` endpoint.
Why it matters now
EPSS 0.00984 62nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @shopify/koa-shopify-auth (npm): 3.1.63
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | koa-shopify-auth | Impacted: v3.1.61-v3.1.62, Fixed: v3.1.63 | — | No fix listed | CNA |
| — | @shopify/koa-shopify-auth (npm) | 3.1.61 to before 3.1.63 | 3.1.63 | Patch available | GHSA-jqh7-w5pr-cr56 |
- koa-shopify-auth Vendor— Affected Impacted: v3.1.61-v3.1.62, Fixed: v3.1.63 Fixed in — No fix listed CNA
- @shopify/koa-shopify-auth (npm) Vendor— Affected 3.1.61 to before 3.1.63 Fixed in 3.1.63 Patch available GHSA-jqh7-w5pr-cr56
Remediation
- Fix · GHSA-jqh7-w5pr-cr56 @shopify/koa-shopify-auth (npm) Fixed in 3.1.63 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8176
- 2026-10-03 Alias added: GHSA-jqh7-w5pr-cr56
References
Sources
- CVE-2020-8176 · CVE Program
- CVE-2020-8176 · NVD
- FIRST EPSS
- GHSA-jqh7-w5pr-cr56 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences