Server-side request forgery in uppy
Priority LOW 35CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
The uppy npm package < 1.13.2 and < 2.0.0-alpha.5 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external networks or otherwise interact with internal systems.
Why it matters now
EPSS 0.0119 68th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @uppy/companion (npm): 1.13.2, 2.0.0-alpha.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | uppy | Fixed Versions: 1.13.2, 2.0.0-alpha.5 | — | No fix listed | CNA |
| — | @uppy/companion (npm) | before 1.13.2 | 1.13.2 | Patch available | GHSA-9m4x-8w29-r78g |
| — | @uppy/companion (npm) | 2.0.0-alpha.0 to before 2.0.0-alpha.5 | 2.0.0-alpha.5 | Patch available | GHSA-9m4x-8w29-r78g |
- uppy Vendor— Affected Fixed Versions: 1.13.2, 2.0.0-alpha.5 Fixed in — No fix listed CNA
- @uppy/companion (npm) Vendor— Affected before 1.13.2 Fixed in 1.13.2 Patch available GHSA-9m4x-8w29-r78g
- @uppy/companion (npm) Vendor— Affected 2.0.0-alpha.0 to before 2.0.0-alpha.5 Fixed in 2.0.0-alpha.5 Patch available GHSA-9m4x-8w29-r78g
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:transloadit:uppy:*:*:*:*:*:node.js:*:* | before 1.13.2 | Vulnerable | transloadit |
| cpe:2.3:a:transloadit:uppy:2.0.0:alpha0:*:*:*:node.js:*:* | 2.0.0 alpha0 | Vulnerable | transloadit |
| cpe:2.3:a:transloadit:uppy:2.0.0:alpha1:*:*:*:node.js:*:* | 2.0.0 alpha1 | Vulnerable | transloadit |
| cpe:2.3:a:transloadit:uppy:2.0.0:alpha2:*:*:*:node.js:*:* | 2.0.0 alpha2 | Vulnerable | transloadit |
| cpe:2.3:a:transloadit:uppy:2.0.0:alpha3:*:*:*:node.js:*:* | 2.0.0 alpha3 | Vulnerable | transloadit |
| cpe:2.3:a:transloadit:uppy:2.0.0:alpha4:*:*:*:node.js:*:* | 2.0.0 alpha4 | Vulnerable | transloadit |
- cpe:2.3:a:transloadit:uppy:*:*:*:*:*:node.js:*:* Versions before 1.13.2 Vulnerable ·transloadit
- cpe:2.3:a:transloadit:uppy:2.0.0:alpha0:*:*:*:node.js:*:* Versions 2.0.0 alpha0 Vulnerable ·transloadit
- cpe:2.3:a:transloadit:uppy:2.0.0:alpha1:*:*:*:node.js:*:* Versions 2.0.0 alpha1 Vulnerable ·transloadit
- cpe:2.3:a:transloadit:uppy:2.0.0:alpha2:*:*:*:node.js:*:* Versions 2.0.0 alpha2 Vulnerable ·transloadit
- cpe:2.3:a:transloadit:uppy:2.0.0:alpha3:*:*:*:node.js:*:* Versions 2.0.0 alpha3 Vulnerable ·transloadit
- cpe:2.3:a:transloadit:uppy:2.0.0:alpha4:*:*:*:node.js:*:* Versions 2.0.0 alpha4 Vulnerable ·transloadit
Remediation
- Fix · GHSA-9m4x-8w29-r78g @uppy/companion (npm) Fixed in 1.13.2 Advisory →
- Fix · GHSA-9m4x-8w29-r78g @uppy/companion (npm) Fixed in 2.0.0-alpha.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8205
- 2026-10-03 Alias added: GHSA-9m4x-8w29-r78g
References
More transloadit Uppy vulnerabilities
- TI-2022-00037 Server-Side Request Forgery (SSRF) in transloadit/uppy CVSS 3.1CRITICAL 9.8
- TI-2022-00448 Server-Side Request Forgery (SSRF) in transloadit/uppy CVSS 3.1HIGH 7.5
Sources
- CVE-2020-8205 · CVE Program
- CVE-2020-8205 · NVD
- FIRST EPSS
- GHSA-9m4x-8w29-r78g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences