A path traversal vulnerability in servey version < 3 allows an attacker to read content of any arbitrary file.
Priority LOW 37CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
A path traversal vulnerability in servey version < 3 allows an attacker to read content of any arbitrary file.
Why it matters now
EPSS 0.01986 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed servey (npm): 3.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | servey | Vulnerable versions < 3 | — | No fix listed | CNA |
| — | servey (npm) | before 3.3.2 | 3.3.2 | Patch available | GHSA-v3px-6cc8-f8j3 |
- servey Vendor— Affected Vulnerable versions < 3 Fixed in — No fix listed CNA
- servey (npm) Vendor— Affected before 3.3.2 Fixed in 3.3.2 Patch available GHSA-v3px-6cc8-f8j3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:servey_project:servey:*:*:*:*:*:node.js:*:* | 2.2.0 to before 3.1.0 | Vulnerable | Servey Project |
- cpe:2.3:a:servey_project:servey:*:*:*:*:*:node.js:*:* Versions 2.2.0 to before 3.1.0 Vulnerable ·Servey Project
Remediation
- Fix · GHSA-v3px-6cc8-f8j3 servey (npm) Fixed in 3.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8214
- 2026-10-03 Alias added: GHSA-v3px-6cc8-f8j3
References
Sources
- CVE-2020-8214 · CVE Program
- CVE-2020-8214 · NVD
- FIRST EPSS
- GHSA-v3px-6cc8-f8j3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences