Command injection in EdgeSwitch firmware v1.9.0 and prior
Priority MEDIUM 45CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-77.
Summary
A command injection vulnerability exists in EdgeSwitch firmware <v1.9.0 that allowed an authenticated read-only user to execute arbitrary shell commands over the HTTP interface, allowing them to escalate privileges.
Why it matters now
EPSS 0.04419 91st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | EdgeSwitch firmware v1.9.0 and prior | Fixed version EdgeSwitch firmware v1.9.1 | — | No fix listed | CNA |
- EdgeSwitch firmware v1.9.0 and prior Vendor— Affected Fixed version EdgeSwitch firmware v1.9.1 Fixed in — No fix listed CNA
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ui:edgeswitch_firmware:*:*:*:*:*:*:*:* | before 1.9.0 | Vulnerable | Ubiquiti |
| cpe:2.3:h:ui:ep-16-xg:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:ep-s16:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-12f:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-16-150w:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-24-250w:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-24-500w:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-24-lite:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-48-500w:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-48-750w:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
- cpe:2.3:a:ui:edgeswitch_firmware:*:*:*:*:*:*:*:* Versions before 1.9.0 Vulnerable ·Ubiquiti
- cpe:2.3:h:ui:ep-16-xg:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:ep-s16:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-12f:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-16-150w:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-24-250w:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-24-500w:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-24-lite:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-48-500w:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-48-750w:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:h:ui:es-48-lite:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:h:ui:es-8-150w:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Ubiquiti |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* | 15.0 sp2 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Vulnerable | openSUSE |
- cpe:2.3:h:ui:es-48-lite:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:h:ui:es-8-150w:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Ubiquiti
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* Versions 15.0 sp2 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8233
- 2026-10-03 Alias added: GHSA-wg23-cr77-5r75
References
Sources
- CVE-2020-8233 · CVE Program
- CVE-2020-8233 · NVD
- FIRST EPSS
- GHSA-wg23-cr77-5r75 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences