Read the docs
TI-2020-06913 Aliases CVE-2020-8620GHSA-p5fp-cw6q-m6xc

Reachable assertion in ISC BIND9

Priority LOW 39CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-617.

Summary

In BIND 9.15.6 -> 9.16.5, 9.17.0 -> 9.17.3, An attacker who can establish a TCP connection with the server and send data on that connection can exploit this to trigger the assertion failure, causing the server to exit.

Why it matters now

EPSS 0.03902 90th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND99.15.6 and later—No fix listedCNA
  • BIND9 VendorISC Affected 9.15.6 and later Fixed in — No fix listed CNA

CPE configurations NVD · 11

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*9.15.6 – 9.16.5; 9.17.0 – 9.17.3VulnerableISC
cpe:2.3:a:isc:bind:9.9.12:s1:*:*:supported_preview:*:*:*9.9.12 s1VulnerableISC
cpe:2.3:a:isc:bind:9.9.13:s1:*:*:supported_preview:*:*:*9.9.13 s1VulnerableISC
cpe:2.3:a:isc:bind:9.11.3:s1:*:*:supported_preview:*:*:*9.11.3 s1VulnerableISC
cpe:2.3:a:isc:bind:9.11.21:s1:*:*:supported_preview:*:*:*9.11.21 s1VulnerableISC
cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*15.1VulnerableopenSUSE
cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:*15.2VulnerableopenSUSE
cpe:2.3:a:netapp:steelstore_cloud_integrated_storage:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*12.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*16.04VulnerableCanonical
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions 9.15.6 – 9.16.5; 9.17.0 – 9.17.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.12:s1:*:*:supported_preview:*:*:* Versions 9.9.12 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.13:s1:*:*:supported_preview:*:*:* Versions 9.9.13 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.3:s1:*:*:supported_preview:*:*:* Versions 9.11.3 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.21:s1:*:*:supported_preview:*:*:* Versions 9.11.21 s1 Vulnerable ·ISC
  • cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
  • cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
  • cpe:2.3:a:netapp:steelstore_cloud_integrated_storage:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Versions 12.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
Show 1 more CPE
CPEVersionsRoleVendor
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical

Remediation

No fixed version listed by the sources yet.

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    ISC BIND9 — GLSA-202008-19

    5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW

    Other records, highest priority first

    • TI-2020-06916 A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.cPriority MEDIUM 42
    • TI-2020-06915 A truncated TSIG response can lead to an assertion failurePriority LOW 38
    • TI-2020-06914 Attempting QNAME minimization after forwarding can lead to an assertion failure in resolver.cPriority LOW 38
  • Advisory ·

    ISC BIND9 — USN-4468-1

    5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW

    Other records, highest priority first

    • TI-2020-06916 A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.cPriority MEDIUM 42
    • TI-2020-06915 A truncated TSIG response can lead to an assertion failurePriority LOW 38
    • TI-2020-06914 Attempting QNAME minimization after forwarding can lead to an assertion failure in resolver.cPriority LOW 38

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 4 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-8620
  2. 2026-10-03 Alias added: GHSA-p5fp-cw6q-m6xc
  3. 2026-10-23 EPSS moved to the 90th–95th percentile

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources