Robustness weakness in AWS KMS and Encryption SDKs
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-327.
Summary
A weak robustness vulnerability exists in the AWS Encryption SDKs for Java, Python, C and Javalcript prior to versions 2.0.0. Due to the non-committing property of AES-GCM (and other AEAD ciphers such as AES-GCM-SIV or (X)ChaCha20Poly1305) used by the SDKs to encrypt messages, an attacker can craft a unique cyphertext which will decrypt to multiple different results, and becomes especially relevant in a multi-recipient setting. We recommend users update their SDK to 2.0.0 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | AWS SDK | stable to before 2.0.0 | 2.0.0 | Patch available | CNA |
| — | com.amazonaws:aws-encryption-sdk-java (Maven) | before 2.0.0 | 2.0.0 | Patch available | GHSA-wqgp-vphw-hphf |
| — | aws-encryption-sdk (PyPI) | before 2.0.0 | 2.0.0 | Patch available | GHSA-wqgp-vphw-hphf |
- AWS SDK VendorAWS Affected stable to before 2.0.0 Fixed in 2.0.0 Patch available CNA
- com.amazonaws:aws-encryption-sdk-java (Maven) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-wqgp-vphw-hphf
- aws-encryption-sdk (PyPI) Vendor— Affected before 2.0.0 Fixed in 2.0.0 Patch available GHSA-wqgp-vphw-hphf
Remediation
- Fix · CNA AWS SDK (Amazon) Fixed in 2.0.0
- Fix · GHSA-wqgp-vphw-hphf com.amazonaws:aws-encryption-sdk-java (Maven) Fixed in 2.0.0 Advisory →
- Fix · GHSA-wqgp-vphw-hphf aws-encryption-sdk (PyPI) Fixed in 2.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8897
- 2026-10-03 Alias added: GHSA-wqgp-vphw-hphf
References
Advisory 2
More Aws Encryption Sdk vulnerabilities
- TI-2024-15698 AWS Encryption SDK for Java Improper Verification of Cryptographic Signature CVSS 3.1MEDIUM 5.3
Sources
- CVE-2020-8897 · CVE Program
- CVE-2020-8897 · NVD
- FIRST EPSS
- GHSA-wqgp-vphw-hphf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences