Confidential Information Disclosure vulnerability in Asylo
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A buffer length validation vulnerability in Asylo versions prior to 0.6.0 allows an attacker to read data they should not have access to. The 'enc_untrusted_recvfrom' function generates a return value which is deserialized by 'MessageReader', and copied into three different 'extents'. The length of the third 'extents' is controlled by the outside world, and not verified on copy, allowing the attacker to force Asylo to copy trusted memory data into an untrusted buffer of significantly small length.. We recommend updating Asylo to version 0.6.0 or later.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Asylo (Google LLC) Fixed in 0.6.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Google Asylo 0.6.0
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2020-07152 Arbitrary trusted memory overwrite vulnerability in AsyloPriority MEDIUM 41
Timeline
- 2026-10-02 Threatist record created from CVE-2020-8905
- 2026-10-03 Alias added: GHSA-xr5f-j5gc-qw6j
More Google Asylo vulnerabilities
- TI-2020-07152 Arbitrary trusted memory overwrite vulnerability in Asylo CVSS 3.1CRITICAL 9.6
- TI-2021-05511 Enclave memory overwrite/overread vulnerability in Asylo UntrustedCacheMalloc::GetBuffer CVSS 3.1HIGH 7.8
- TI-2021-05510 Arbitrary enclave memory overwrite vulnerability in Asylo TrustedPrimitives::UntrustedCall CVSS 3.1HIGH 7.8
- TI-2021-05509 Arbitrary enclave memory overread vulnerability in Asylo TrustedPrimitives::UntrustedCall CVSS 3.1HIGH 7.8
- TI-2020-07169 Memory corruption in Google Asylo CVSS 3.1HIGH 7.8
- TI-2021-05512 Memory overread secure enclave in Asylo 0.6.2 CVSS 3.1MEDIUM 5.5
Sources
- CVE-2020-8905 · CVE Program
- CVE-2020-8905 · NVD
- FIRST EPSS
- GHSA-xr5f-j5gc-qw6j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences