Joplin through 1.0.184 allows Arbitrary File Read via XSS.
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Joplin through 1.0.184 allows Arbitrary File Read via XSS.
Why it matters now
EPSS 0.03566 89th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed joplin (npm): 1.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | joplin (npm) | before 1.2.1 | 1.2.1 | Patch available | GHSA-6r7x-hc8m-985r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- joplin (npm) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-6r7x-hc8m-985r
Remediation
- Fix · GHSA-6r7x-hc8m-985r joplin (npm) Fixed in 1.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-9038
- 2026-10-03 Alias added: GHSA-6r7x-hc8m-985r
References
Exploit 1
Patch 2
More laurent22 Joplin vulnerabilities
- TI-2023-24472 Arbitrary code execution on click of PDF links in Joplin CVSS 3.1CRITICAL 9.0
- TI-2024-32950 Remote Code Execution on click of <a> Link in markdown preview CVSS 3.1CRITICAL 9.6
- TI-2024-27054 Joplin has a parsing error leading to Cross-site Scripting (XSS) CVSS 3.1CRITICAL 9.7
- TI-2025-17795 Cross-site Scripting (XSS) in Rich Text Editor allows arbitrary code execution in Joplin CVSS 3.1CRITICAL 9.6
- TI-2025-19991 Privilege escalation in Joplin server via user patch endpoint CVSS 3.1HIGH 8.8
- TI-2024-35730 Lack of validation on openExternal allows 1 click remote code execution in joplin CVSS 3.1HIGH 8.8
Sources
- CVE-2020-9038 · CVE Program
- CVE-2020-9038 · NVD
- FIRST EPSS
- GHSA-6r7x-hc8m-985r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences