Read the docs
TI-2020-07518 Aliases CVE-2020-9402GHSA-3gh2-xw74-jmcw

Django 1.11 before 1.11.29, 2.2 before 2.2.11, and 3.0 before 3.0.4 allows SQL Injection…

Priority MEDIUM 58CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 8 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-89.

Summary

Django 1.11 before 1.11.29, 2.2 before 2.2.11, and 3.0 before 3.0.4 allows SQL Injection if untrusted data is used as a tolerance parameter in GIS functions and aggregates on Oracle. By passing a suitably crafted tolerance to GIS functions and aggregates on Oracle, it was possible to break escaping and inject malicious SQL.

Why it matters now

EPSS 0.22513 97th percentileScored 2026-11-07
Fix Partial Django (PyPI): 1.11.29, 2.2.11, 3.0.4Red Hat: 1 advisoryRed Hat: 2 fixed, 8 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—Django (PyPI)1.11 to before 1.11.291.11.29Patch availableGHSA-3gh2-xw74-jmcw
—Django (PyPI)2.2 to before 2.2.112.2.11Patch availableGHSA-3gh2-xw74-jmcw
—Django (PyPI)3.0 to before 3.0.43.0.4Patch availableGHSA-3gh2-xw74-jmcw
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • Django (PyPI) Vendor— Affected 1.11 to before 1.11.29 Fixed in 1.11.29 Patch available GHSA-3gh2-xw74-jmcw
  • Django (PyPI) Vendor— Affected 2.2 to before 2.2.11 Fixed in 2.2.11 Patch available GHSA-3gh2-xw74-jmcw
  • Django (PyPI) Vendor— Affected 3.0 to before 3.0.4 Fixed in 3.0.4 Patch available GHSA-3gh2-xw74-jmcw

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*1.11 to before 1.11.29; 2.2 to before 2.2.11; 3.0 to before 3.0.4Vulnerabledjangoproject
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
cpe:2.3:a:netapp:steelstore_cloud_integrated_storage:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*16.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:*19.10VulnerableCanonical
  • cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 1.11 to before 1.11.29; 2.2 to before 2.2.11; 3.0 to before 3.0.4 Vulnerable ·djangoproject
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
  • cpe:2.3:a:netapp:steelstore_cloud_integrated_storage:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical

Remediation

  • Fix · GHSA-3gh2-xw74-jmcw Django (PyPI) Fixed in 1.11.29 Advisory →
  • Fix · GHSA-3gh2-xw74-jmcw Django (PyPI) Fixed in 2.2.11 Advisory →
  • Fix · GHSA-3gh2-xw74-jmcw Django (PyPI) Fixed in 3.0.4 Advisory →

Red Hat 1 advisory

  • RHSA-2021:1313 Released 2021-04-21 · Red Hat rating Moderate
    Satellite 6.9 Release
    • Red Hat Satellite 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
    • Red Hat Satellite Capsule 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ceph Storage 2AffectedNo fix planned: Will not fix
Red Hat Ceph Storage 3AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 10 (Newton)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 13 (Queens)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 15 (Stein)AffectedNo fix planned: Will not fix
Red Hat OpenStack Platform 16 (Train)AffectedNo fix planned: Will not fix
Red Hat Storage 3AffectedNo fix yet: Fix deferred
Red Hat Update Infrastructure 3 for Cloud ProvidersAffectedNo fix yet: Fix deferred
Red Hat Satellite 6.9Fixed RHSA-2021:1313
Red Hat Satellite Capsule 6.9Fixed RHSA-2021:1313
Not affected: 2 products
  • Red Hat Satellite 6.9
  • Red Hat Satellite Capsule 6.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-9402
  2. 2026-10-03 Alias added: GHSA-3gh2-xw74-jmcw

References

Sources