Cross-site scripting in Apache Airflow
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was found in Apache Airflow versions 1.10.10 and below. A stored XSS vulnerability was discovered in the Chart pages of the the "classic" UI.
Why it matters now
EPSS 0.0276 86th percentileScored 2026-11-07
Fix Fixed apache-airflow (PyPI): 1.10.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow | up to 1.10.10 | — | No fix listed | CNA |
| — | apache-airflow (PyPI) | before 1.10.11 | 1.10.11 | Patch available | GHSA-j38c-25fj-mr84 |
- Apache Airflow VendorApache Affected up to 1.10.10 Fixed in — No fix listed CNA
- apache-airflow (PyPI) Vendor— Affected before 1.10.11 Fixed in 1.10.11 Patch available GHSA-j38c-25fj-mr84
Remediation
- Fix · GHSA-j38c-25fj-mr84 apache-airflow (PyPI) Fixed in 1.10.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-9485
- 2026-10-03 Alias added: GHSA-j38c-25fj-mr84
References
Advisory 3
More Apache Airflow vulnerabilities
- TI-2020-10905 Missing authentication in Apache Airflow KEVCVSS 3.1CRITICAL 9.8
- TI-2020-09638 OS command injection in Apache Airflow KEVCVSS 3.1HIGH 8.8
- TI-2022-19017 Apache Airflow <2.4.0 has an RCE in a bash example CVSS 3.1HIGH 8.8
- TI-2021-16140 Apache Airflow: Variable Import endpoint missed authentication check CVSS 3.1CRITICAL 9.8
- TI-2022-08169 Apache Airflow: RCE in example DAGs CVSS 3.1HIGH 8.8
- TI-2024-26776 Apache Airflow: DAG Author Code Execution possibility in airflow-scheduler CVSS 3.1HIGH 8.8
Sources
- CVE-2020-9485 · CVE Program
- CVE-2020-9485 · NVD
- FIRST EPSS
- GHSA-j38c-25fj-mr84 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences