Incorrect authorization in Adobe Magento
Priority MEDIUM 41CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have an authorization bypass vulnerability. Successful exploitation could lead to potentially unauthorized product discounts.
Why it matters now
EPSS 0.05009 92nd percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.4-p2magento/core (Packagist): 1.9.4.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento | 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier versions | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | up to 2.2.11 | — | No fix listed | GHSA-8wm7-h2qh-ff4c |
| — | magento/community-edition (Packagist) | 2.3.0 to before 2.3.4-p2 | 2.3.4-p2 | Patch available | GHSA-8wm7-h2qh-ff4c |
| — | magento/core (Packagist) | before 1.9.4.5 | 1.9.4.5 | Patch available | GHSA-8wm7-h2qh-ff4c |
| — | magento/project-community-edition (Packagist) | up to 2.0.2 | — | No fix listed | GHSA-8wm7-h2qh-ff4c |
- Magento VendorAdobe Affected 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier versions Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected up to 2.2.11 Fixed in — No fix listed GHSA-8wm7-h2qh-ff4c
- magento/community-edition (Packagist) Vendor— Affected 2.3.0 to before 2.3.4-p2 Fixed in 2.3.4-p2 Patch available GHSA-8wm7-h2qh-ff4c
- magento/core (Packagist) Vendor— Affected before 1.9.4.5 Fixed in 1.9.4.5 Patch available GHSA-8wm7-h2qh-ff4c
- magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-8wm7-h2qh-ff4c
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:community:*:*:* | up to 1.9.4.4 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:enterprise:*:*:* | up to 1.14.4.4 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.2.0 – 2.2.11 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.2.0 – 2.2.11 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | 2.3.0 – 2.3.4 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | 2.3.0 – 2.3.4 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:community:*:*:* Versions up to 1.9.4.4 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:enterprise:*:*:* Versions up to 1.14.4.4 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.2.0 – 2.2.11 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.2.0 – 2.2.11 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions 2.3.0 – 2.3.4 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions 2.3.0 – 2.3.4 Vulnerable ·Magento
Remediation
- Fix · GHSA-8wm7-h2qh-ff4c magento/community-edition (Packagist) Fixed in 2.3.4-p2 Advisory →
- Fix · GHSA-8wm7-h2qh-ff4c magento/core (Packagist) Fixed in 1.9.4.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-9587
- 2026-10-03 Alias added: GHSA-8wm7-h2qh-ff4c
References
More Adobe vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-9587 · CVE Program
- CVE-2020-9587 · NVD
- FIRST EPSS
- GHSA-8wm7-h2qh-ff4c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences