Cross-site scripting in Adobe Magento
Priority MEDIUM 50CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Magento versions 2.3.5-p1 and earlier, and 2.3.5-p1 and earlier have a dom-based cross-site scripting vulnerability. Successful exploitation could lead to arbitrary code execution.
Why it matters now
EPSS 0.06018 93rd percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.5-p2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento | 2.3.5-p1 and earlier, and 2.3.5-p1 and earlier versions | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | before 2.3.5-p2 | 2.3.5-p2 | Patch available | GHSA-g7pc-799q-743f |
| — | magento/project-community-edition (Packagist) | up to 2.0.2 | — | No fix listed | GHSA-g7pc-799q-743f |
- Magento VendorAdobe Affected 2.3.5-p1 and earlier, and 2.3.5-p1 and earlier versions Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected before 2.3.5-p2 Fixed in 2.3.5-p2 Patch available GHSA-g7pc-799q-743f
- magento/project-community-edition (Packagist) Vendor— Affected up to 2.0.2 Fixed in — No fix listed GHSA-g7pc-799q-743f
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* | before 2.3.5 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* | before 2.3.5 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:-:*:*:commerce:*:*:* | 2.3.5 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:-:*:*:open_source:*:*:* | 2.3.5 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:p1:*:*:commerce:*:*:* | 2.3.5 p1 | Vulnerable | Magento |
| cpe:2.3:a:magento:magento:2.3.5:p1:*:*:open_source:*:*:* | 2.3.5 p1 | Vulnerable | Magento |
- cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* Versions before 2.3.5 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:* Versions before 2.3.5 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:-:*:*:commerce:*:*:* Versions 2.3.5 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:-:*:*:open_source:*:*:* Versions 2.3.5 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:p1:*:*:commerce:*:*:* Versions 2.3.5 p1 Vulnerable ·Magento
- cpe:2.3:a:magento:magento:2.3.5:p1:*:*:open_source:*:*:* Versions 2.3.5 p1 Vulnerable ·Magento
Remediation
- Fix · GHSA-g7pc-799q-743f magento/community-edition (Packagist) Fixed in 2.3.5-p2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-9691
- 2026-10-03 Alias added: GHSA-g7pc-799q-743f
References
More Adobe vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2026-35688 ColdFusion | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22) KEVCVSS 3.1CRITICAL 10.0
- TI-2025-34084 Adobe Experience Manager | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2023-19615 Analysis CVE-2023-29300 Bypass: Adobe ColdFusion Pre-Auth RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2023-13696 Adobe ColdFusion Deserialization of Untrusted Data Arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2020-9691 · CVE Program
- CVE-2020-9691 · NVD
- FIRST EPSS
- GHSA-g7pc-799q-743f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences