WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right…
Priority MEDIUM 50CWE-416Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 9 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.
Why it matters now
EPSS 0.04987 92nd percentileScored 2026-11-07
Fix Partial Red Hat: 2 advisoriesRed Hat: 9 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:webkitgtk:webkitgtk:*:*:*:*:*:*:*:* | before 2.28.0 | Vulnerable | WebKitGTK |
| cpe:2.3:a:wpewebkit:wpe_webkit:*:*:*:*:*:*:*:* | before 2.28.0 | Vulnerable | Wpewebkit |
| cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* | 30 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* | 19.10 | Vulnerable | Canonical |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:webkitgtk:webkitgtk:*:*:*:*:*:*:*:* Versions before 2.28.0 Vulnerable ·WebKitGTK
- cpe:2.3:a:wpewebkit:wpe_webkit:*:*:*:*:*:*:*:* Versions before 2.28.0 Vulnerable ·Wpewebkit
- cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:19.10:*:*:*:*:*:*:* Versions 19.10 Vulnerable ·Canonical
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
Red Hat 2 advisories
- RHSA-2020:4451 Released 2020-11-04 · Red Hat rating ModerateGNOME security, bug fix, and enhancement update
- Red Hat CodeReady Linux Builder (v. 8) LibRaw-devel-0.19.5-2.el8
- Red Hat Enterprise Linux AppStream (v. 8) LibRaw-0.19.5-2.el8, gnome-settings-daemon-3.32.0-11.el8, webkit2gtk3-2.28.4-1.el8 +3
- RHSA-2020:4035 Released 2020-09-29 · Red Hat rating Moderatewebkitgtk4 security, bug fix, and enhancement update
- Red Hat Enterprise Linux Client (v. 7) webkitgtk4-2.28.2-2.el7, webkitgtk4-jsc-2.28.2-2.el7
- Red Hat Enterprise Linux Client Optional (v. 7) webkitgtk4-devel-2.28.2-2.el7, webkitgtk4-doc-2.28.2-2.el7, webkitgtk4-jsc-devel-2.28.2-2.el7
- Red Hat Enterprise Linux ComputeNode (v. 7) webkitgtk4-2.28.2-2.el7, webkitgtk4-jsc-2.28.2-2.el7
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) webkitgtk4-devel-2.28.2-2.el7, webkitgtk4-doc-2.28.2-2.el7, webkitgtk4-jsc-devel-2.28.2-2.el7
- Red Hat Enterprise Linux Server (v. 7) webkitgtk4-2.28.2-2.el7, webkitgtk4-2.28.2-2.el7.ppc, webkitgtk4-devel-2.28.2-2.el7 +3
- Red Hat Enterprise Linux Server Optional (v. 7) webkitgtk4-devel-2.28.2-2.el7, webkitgtk4-devel-2.28.2-2.el7.ppc, webkitgtk4-doc-2.28.2-2.el7 +2
- Red Hat Enterprise Linux Workstation (v. 7) webkitgtk4-2.28.2-2.el7, webkitgtk4-devel-2.28.2-2.el7, webkitgtk4-jsc-2.28.2-2.el7 +1
- Red Hat Enterprise Linux Workstation Optional (v. 7) webkitgtk4-doc-2.28.2-2.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2020:4451 |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2020:4035 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2020:4035 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2020:4035 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2020:4035 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:4035 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2020:4035 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:4035 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2020:4035 |
Not affected: 3 products
- Red Hat CodeReady Linux Builder (v. 8)
- Red Hat Enterprise Linux AppStream (v. 8)
- Red Hat Enterprise Linux BaseOS (v. 8)
Timeline
- 2026-10-02 Threatist record created from CVE-2020-10018
- 2026-10-03 Alias added: GHSA-37vm-m2gx-6h3h
References
Sources
- CVE-2020-10018 · CVE Program
- CVE-2020-10018 · NVD
- FIRST EPSS
- GHSA-37vm-m2gx-6h3h · GitHub Advisory Database · CC BY 4.0
- CVE-2020-10018 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences