Sonatype Nexus Repository before 3.21.2 allows XSS.
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Sonatype Nexus Repository before 3.21.2 allows XSS.
Why it matters now
EPSS 0.00918 60th percentileScored 2026-11-07
Fix Fixed org.sonatype.nexus:nexus-core (Maven): 3.21.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.sonatype.nexus:nexus-core (Maven) | before 3.21.2 | 3.21.2 | Patch available | GHSA-3944-787c-f852 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.sonatype.nexus:nexus-core (Maven) Vendor— Affected before 3.21.2 Fixed in 3.21.2 Patch available GHSA-3944-787c-f852
Remediation
- Fix · GHSA-3944-787c-f852 org.sonatype.nexus:nexus-core (Maven) Fixed in 3.21.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-10203
- 2026-10-03 Alias added: GHSA-3944-787c-f852
References
More Sonatype Nexus vulnerabilities
- TI-2020-08218 Sonatype Nexus Repository before 3.21.2 allows JavaEL Injection (issue 1 of 2). KEVCVSS 3.1HIGH 8.8
- TI-2020-08220 Sonatype Nexus Repository before 3.21.2 allows Remote Code Execution. CVSS 3.1HIGH 7.2
- TI-2020-09183 Sonatype Nexus Repository Manager 3.x up to and including 3.21.2 has Incorrect Access Control. CVSS 3.1HIGH 8.8
- TI-2014-00735 Sonatype Nexus 1.x and 2.x before 2.7.1 allows remote attackers to create arbitrary… CVSS 2.0HIGH 7.5
- TI-2014-07618 Directory traversal vulnerability in Sonatype Nexus OSS and Pro before 2.11.1-01 allows… CVSS 2.0HIGH 7.5
- TI-2014-01597 Unspecified vulnerability in Sonatype Nexus OSS and Pro 2.4.0 through 2.7.1 allows… CVSS 2.0HIGH 7.5
Sources
- CVE-2020-10203 · CVE Program
- CVE-2020-10203 · NVD
- FIRST EPSS
- GHSA-3944-787c-f852 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences