The Library API in buger jsonparser through 2019-12-04 allows attackers to cause a denial…
Priority LOW 38CWE-835Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-835.
Summary
The Library API in buger jsonparser through 2019-12-04 allows attackers to cause a denial of service (infinite loop) via a Delete call.
Why it matters now
EPSS 0.02584 85th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/buger/jsonparser (Go): 1.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/buger/jsonparser (Go) | before 1.0.0 | 1.0.0 | Patch available | GHSA-rmh2-65xw-9m6q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/buger/jsonparser (Go) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-rmh2-65xw-9m6q
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jsonparser_project:jsonparser:*:*:*:*:*:*:*:* | before 1.0.0 | Vulnerable | Jsonparser Project |
| cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* | 31 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
- cpe:2.3:a:jsonparser_project:jsonparser:*:*:*:*:*:*:*:* Versions before 1.0.0 Vulnerable ·Jsonparser Project
- cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-rmh2-65xw-9m6q github.com/buger/jsonparser (Go) Fixed in 1.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Virtualization 2
Timeline
- 2026-10-02 Threatist record created from CVE-2020-10675
- 2026-10-03 Alias added: GHSA-rmh2-65xw-9m6q
References
Advisory 3
Other 6
- https://github.com/buger/jsonparser/pull/192
- https://github.com/buger/jsonparser/commit/91ac96899e492584984ded0c8f9a08f10b473717
- https://github.com/buger/jsonparser
- https://lists.fedoraproject.org/archives/list/[email protected]/message/4C7PV6KEUUM76V4B2J5IFN2U6LEOWB67
- https://lists.fedoraproject.org/archives/list/[email protected]/message/6KUHKDQSEYJNROA66OMN6AAQMGAAN6WI
- https://pkg.go.dev/vuln/GO-2021-0089
Sources
- CVE-2020-10675 · CVE Program
- CVE-2020-10675 · NVD
- FIRST EPSS
- GHSA-rmh2-65xw-9m6q · GitHub Advisory Database · CC BY 4.0
- CVE-2020-10675 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences