Read the docs
TI-2020-08605 Aliases CVE-2020-10704GHSA-hxwv-6335-26h5

Uncontrolled recursion in Red Hat samba

Priority LOW 39CWE-674Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-674.

Summary

A flaw was found when using samba as an Active Directory Domain Controller. Due to the way samba handles certain requests as an Active Directory Domain Controller LDAP server, an unauthorized user can cause a stack overflow leading to a denial of service. The highest threat from this vulnerability is to system availability. This issue affects all samba versions before 4.10.15, before 4.11.8 and before 4.12.2.

Why it matters now

EPSS 0.03542 89th percentileScored 2026-11-07
Fix Fixed samba (Red Hat): 4.10.15, 4.11.8, 4.12.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Red Hatsambabefore 4.10.15; before 4.11.8; before 4.12.24.10.15, 4.11.8, 4.12.2Patch availableCNA
  • samba VendorRed Hat Affected before 4.10.15; before 4.11.8; before 4.12.2 Fixed in 4.10.15, 4.11.8, 4.12.2 Patch available CNA

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*4.0.0 to before 4.10.15; 4.11.0 to before 4.11.8; 4.12.0 to before 4.12.2VulnerableSamba
cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:*30VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:*15.2VulnerableopenSUSE
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.10.15; 4.11.0 to before 4.11.8; 4.12.0 to before 4.12.2 Vulnerable ·Samba
  • cpe:2.3:o:fedoraproject:fedora:30:*:*:*:*:*:*:* Versions 30 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
  • cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · CNA samba (Red Hat) Fixed in 4.10.15, 4.11.8, 4.12.2

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    Red Hat samba — FEDORA-2020-9cf0b1c8f1

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

  • Advisory ·

    Red Hat samba — FEDORA-2020-e244c98af5

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 5 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Storage 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-10704
  2. 2026-10-03 Alias added: GHSA-hxwv-6335-26h5

References

  • TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
  • TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
See all 7413 →

Sources