A flaw was found in the use of insufficiently random values in Ansible.
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
A flaw was found in the use of insufficiently random values in Ansible. Two random password lookups of the same length generate the equal value as the template caching action for the same file since no re-evaluation happens. The highest threat from this vulnerability would be that all passwords are exposed at once for the file. This flaw affects Ansible Engine versions before 2.9.6.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Ansible | ansible-engine 2.9.6 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.9.6 | 2.9.6 | Patch available | GHSA-r6h7-5pq2-j77h |
- Ansible Vendor— Affected ansible-engine 2.9.6 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.9.6 Fixed in 2.9.6 Patch available GHSA-r6h7-5pq2-j77h
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* | before 2.9.6 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Running on | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Running on | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:redhat:ansible_engine:*:*:*:*:*:*:*:* Versions before 2.9.6 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Running on ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Running on ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-r6h7-5pq2-j77h ansible (PyPI) Fixed in 2.9.6 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Engine 2.9 for RHEL 7 Server | Fixed | — |
| Red Hat Ansible Engine 2.9 for RHEL 8 | Fixed | — |
| Red Hat Ansible Tower 3.6 for RHEL 7 | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-10729
- 2026-10-03 Alias added: GHSA-r6h7-5pq2-j77h
References
Advisory 4
Other 5
- https://github.com/ansible/ansible/pull/67429
- https://github.com/ansible/ansible/commit/c520d70bf4748c8ee6718a7d0d0254051ba1c2e9
- https://github.com/ansible/ansible
- https://github.com/ansible/ansible/blob/v2.9.6/changelogs/CHANGELOG-v2.9.rst
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-105.yaml
Sources
- CVE-2020-10729 · CVE Program
- CVE-2020-10729 · NVD
- FIRST EPSS
- GHSA-r6h7-5pq2-j77h · GitHub Advisory Database · CC BY 4.0
- CVE-2020-10729 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences