Insufficiently protected credentials in Red Hat openstack-cinder
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 3 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-522.
Summary
An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | openstack-cinder | all openstack-cinder versions before openstack-cinder 14.1.0; all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0; all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0 | — | No fix listed | CNA |
| — | cinder (PyPI) | 14.0.0 to before 14.1.0 | 14.1.0 | Patch available | GHSA-v3m2-pg96-w33m |
| — | cinder (PyPI) | 15.0.0 to before 15.2.0 | 15.2.0 | Patch available | GHSA-v3m2-pg96-w33m |
| — | cinder (PyPI) | 16.0.0 to before 16.1.0 | 16.1.0 | Patch available | GHSA-v3m2-pg96-w33m |
| — | os-brick (PyPI) | 2.8.0 to before 2.8.6 | 2.8.6 | Patch available | GHSA-v3m2-pg96-w33m |
| — | os-brick (PyPI) | 2.10.0 to before 2.10.4 | 2.10.4 | Patch available | GHSA-v3m2-pg96-w33m |
| — | os-brick (PyPI) | 3.0.0 to before 3.0.2 | 3.0.2 | Patch available | GHSA-v3m2-pg96-w33m |
- openstack-cinder VendorRed Hat Affected all openstack-cinder versions before openstack-cinder 14.1.0; all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0; all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0 Fixed in — No fix listed CNA
- cinder (PyPI) Vendor— Affected 14.0.0 to before 14.1.0 Fixed in 14.1.0 Patch available GHSA-v3m2-pg96-w33m
- cinder (PyPI) Vendor— Affected 15.0.0 to before 15.2.0 Fixed in 15.2.0 Patch available GHSA-v3m2-pg96-w33m
- cinder (PyPI) Vendor— Affected 16.0.0 to before 16.1.0 Fixed in 16.1.0 Patch available GHSA-v3m2-pg96-w33m
- os-brick (PyPI) Vendor— Affected 2.8.0 to before 2.8.6 Fixed in 2.8.6 Patch available GHSA-v3m2-pg96-w33m
- os-brick (PyPI) Vendor— Affected 2.10.0 to before 2.10.4 Fixed in 2.10.4 Patch available GHSA-v3m2-pg96-w33m
- os-brick (PyPI) Vendor— Affected 3.0.0 to before 3.0.2 Fixed in 3.0.2 Patch available GHSA-v3m2-pg96-w33m
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:openstack-cinder:*:*:*:*:*:*:*:* | before 14.1.0; 15.0.0 to before 15.2.0; 16.0.0 to before 16.1.0 | Vulnerable | Red Hat |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Vulnerable | Canonical |
- cpe:2.3:a:redhat:openstack-cinder:*:*:*:*:*:*:*:* Versions before 14.1.0; 15.0.0 to before 15.2.0; 16.0.0 to before 16.1.0 Vulnerable ·Red Hat
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
Remediation
- Fix · GHSA-v3m2-pg96-w33m cinder (PyPI) Fixed in 14.1.0 Advisory →
- Fix · GHSA-v3m2-pg96-w33m cinder (PyPI) Fixed in 15.2.0 Advisory →
- Fix · GHSA-v3m2-pg96-w33m cinder (PyPI) Fixed in 16.1.0 Advisory →
- Fix · GHSA-v3m2-pg96-w33m os-brick (PyPI) Fixed in 2.8.6 Advisory →
- Fix · GHSA-v3m2-pg96-w33m os-brick (PyPI) Fixed in 2.10.4 Advisory →
- Fix · GHSA-v3m2-pg96-w33m os-brick (PyPI) Fixed in 3.0.2 Advisory →
Red Hat 2 advisories
- RHSA-2020:4391 Released 2020-10-28 · Red Hat rating Moderateopenstack-cinder security update
- Red Hat OpenStack Platform 13.0 openstack-cinder-1:12.0.10-19.el7ost, python-cinder-1:12.0.10-19.el7ost
- Red Hat OpenStack Platform 13.0 for RHEL 7.6 EUS Server openstack-cinder-1:12.0.10-19.el7ost, python-cinder-1:12.0.10-19.el7ost
- RHSA-2020:4283 Released 2020-10-28 · Red Hat rating Moderateopenstack-cinder security update
- Red Hat OpenStack Platform 16.1 openstack-cinder-1:15.3.1-1.20200914173114.00ac80b.el8ost, python3-cinder-1:15.3.1-1.20200914173114.00ac80b.el8ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 15 (Stein) | Affected | No fix planned: Out of support scope |
| Red Hat OpenStack Platform 13.0 | Fixed | RHSA-2020:4391 |
| Red Hat OpenStack Platform 13.0 for RHEL 7.6 EUS Server | Fixed | RHSA-2020:4391 |
| Red Hat OpenStack Platform 16.1 | Fixed | RHSA-2020:4283 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-10755
- 2026-10-03 Alias added: GHSA-v3m2-pg96-w33m
References
Advisory 3
Other 6
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10755
- https://github.com/openstack/cinder/commit/ba785eef5f515b869c0d68016e84bb74f76ab45e
- https://github.com/openstack/os-brick/commit/4047948f1ac8055a025972ad73ec3ec421450775
- https://bugs.launchpad.net/cinder/+bug/1823200
- https://github.com/pypa/advisory-database/tree/main/vulns/cinder/PYSEC-2020-228.yaml
- https://usn.ubuntu.com/4420-1
Sources
- CVE-2020-10755 · CVE Program
- CVE-2020-10755 · NVD
- FIRST EPSS
- GHSA-v3m2-pg96-w33m · GitHub Advisory Database · CC BY 4.0
- CVE-2020-10755 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences