Read the docs
TI-2020-08838 Aliases CVE-2020-10960GHSA-pfm2-mqwj-ggm5

In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes…

Priority LOW 26CWE-74Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Partial Red Hat: 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.

Summary

In MediaWiki before 1.34.1, users can add various Cascading Style Sheets (CSS) classes (which can affect what content is shown or hidden in the user interface) to arbitrary DOM nodes via HTML content within a MediaWiki page. This occurs because jquery.makeCollapsible allows applying an event handler to any Cascading Style Sheets (CSS) selector. There is no known way to exploit this for cross-site scripting (XSS).

Why it matters now

EPSS 0.01152 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial mediawiki/core (Packagist): 1.31.7, 1.33.3, 1.34.1Red Hat: 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—mediawiki/core (Packagist)1.31.0 to before 1.31.71.31.7Patch availableGHSA-pfm2-mqwj-ggm5
—mediawiki/core (Packagist)1.33.0 to before 1.33.31.33.3Patch availableGHSA-pfm2-mqwj-ggm5
—mediawiki/core (Packagist)1.34.0 to before 1.34.11.34.1Patch availableGHSA-pfm2-mqwj-ggm5
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • mediawiki/core (Packagist) Vendor— Affected 1.31.0 to before 1.31.7 Fixed in 1.31.7 Patch available GHSA-pfm2-mqwj-ggm5
  • mediawiki/core (Packagist) Vendor— Affected 1.33.0 to before 1.33.3 Fixed in 1.33.3 Patch available GHSA-pfm2-mqwj-ggm5
  • mediawiki/core (Packagist) Vendor— Affected 1.34.0 to before 1.34.1 Fixed in 1.34.1 Patch available GHSA-pfm2-mqwj-ggm5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:*before 1.34.1Vulnerablemediawiki
  • cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions before 1.34.1 Vulnerable ·mediawiki

Remediation

  • Fix · GHSA-pfm2-mqwj-ggm5 mediawiki/core (Packagist) Fixed in 1.31.7 Advisory →
  • Fix · GHSA-pfm2-mqwj-ggm5 mediawiki/core (Packagist) Fixed in 1.33.3 Advisory →
  • Fix · GHSA-pfm2-mqwj-ggm5 mediawiki/core (Packagist) Fixed in 1.34.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.11AffectedNo fix planned: Will not fix
Red Hat OpenShift Container Platform 4AffectedNo fix planned: Will not fix

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-10960
  2. 2026-10-03 Alias added: GHSA-pfm2-mqwj-ggm5

References

  • TI-2023-18933 An issue was discovered in the CheckUser extension for MediaWiki through 1.39.3. CVSS 3.1CRITICAL 9.8
  • TI-2023-13576 An issue was discovered in MediaWiki before 1.35.10, 1.36.x through 1.38.x before 1.38.6… CVSS 3.1CRITICAL 9.8
  • TI-2023-03312 Stored XSS leads to privilege escalation in MediaWiki v1.40.0 CVSS 3.1CRITICAL 9.0
  • TI-2026-42109 Cross-site request forgery in Wikimedia Foundation Mediawiki - RedirectManager Extension CVSS 4.0MEDIUM 6.9
  • TI-2024-22822 An issue was discovered in includes/CommentFormatter/CommentParser.php in MediaWiki… CVSS 3.1HIGH 7.4
  • TI-2023-18935 An issue was discovered in the ProofreadPage (aka Proofread Page) extension for MediaWiki… CVSS 3.1MEDIUM 5.3
See all 416 →

Sources