Remote Code Execution (RCE) vulnerability in dropwizard-validation
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| dropwizard | dropwizard | before 1.3.21; 2.0.0 to before 2.0.3 | 1.3.21, 2.0.3 | Patch available | CNA |
| — | io.dropwizard:dropwizard-validation (Maven) | before 1.3.21 | 1.3.21 | Patch available | GHSA-8jpx-m2wh-2v34 |
| — | io.dropwizard:dropwizard-validation (Maven) | 2.0.0 to before 2.0.3 | 2.0.3 | Patch available | GHSA-8jpx-m2wh-2v34 |
- dropwizard Vendordropwizard Affected before 1.3.21; 2.0.0 to before 2.0.3 Fixed in 1.3.21, 2.0.3 Patch available CNA
- io.dropwizard:dropwizard-validation (Maven) Vendor— Affected before 1.3.21 Fixed in 1.3.21 Patch available GHSA-8jpx-m2wh-2v34
- io.dropwizard:dropwizard-validation (Maven) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-8jpx-m2wh-2v34
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dropwizard:dropwizard_validation:*:*:*:*:*:*:*:* | before 1.3.21; 2.0.0 to before 2.0.3 | Vulnerable | dropwizard |
- cpe:2.3:a:dropwizard:dropwizard_validation:*:*:*:*:*:*:*:* Versions before 1.3.21; 2.0.0 to before 2.0.3 Vulnerable ·dropwizard
Remediation
- Fix · CNA dropwizard (dropwizard) Fixed in 1.3.21, 2.0.3
- Fix · GHSA-8jpx-m2wh-2v34 io.dropwizard:dropwizard-validation (Maven) Fixed in 1.3.21 Advisory →
- Fix · GHSA-8jpx-m2wh-2v34 io.dropwizard:dropwizard-validation (Maven) Fixed in 2.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-11002
- 2026-10-03 Alias added: GHSA-8jpx-m2wh-2v34
References
Patch 3
Advisory 4
- https://github.com/dropwizard/dropwizard/security/advisories/GHSA-8jpx-m2wh-2v34
- https://docs.jboss.org/hibernate/validator/6.1/reference/en-US/html_single/#section-hibernateconstraintvalidatorcontext
- https://github.com/dropwizard/dropwizard/security/policy#reporting-a-vulnerability
- https://nvd.nist.gov/vuln/detail/CVE-2020-11002
More Dropwizard Validation vulnerabilities
- TI-2020-04301 Remote Code Execution (RCE) vulnerability in dropwizard-validation CVSS 3.1HIGH 8.8
Sources
- CVE-2020-11002 · CVE Program
- CVE-2020-11002 · NVD
- FIRST EPSS
- GHSA-8jpx-m2wh-2v34 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences