Cross-Site Scripting in Kaminari
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Kaminari before 1.2.1, there is a vulnerability that would allow an attacker to inject arbitrary code into pages with pagination links. This has been fixed in 1.2.1.
Why it matters now
EPSS 0.01546 75th percentileScored 2026-11-07
Fix Fixed Kaminari (kaminari): 1.2.1kaminari (RubyGems): 1.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| kaminari | Kaminari | before 1.2.1 | 1.2.1 | Patch available | CNA |
| — | kaminari (RubyGems) | before 1.2.1 | 1.2.1 | Patch available | GHSA-r5jw-62xg-j433 |
- Kaminari Vendorkaminari Affected before 1.2.1 Fixed in 1.2.1 Patch available CNA
- kaminari (RubyGems) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-r5jw-62xg-j433
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kaminari_project:kaminari:*:*:*:*:*:*:*:* | before 1.2.1 | Vulnerable | Kaminari Project |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:kaminari_project:kaminari:*:*:*:*:*:*:*:* Versions before 1.2.1 Vulnerable ·Kaminari Project
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Kaminari (kaminari) Fixed in 1.2.1
- Fix · GHSA-r5jw-62xg-j433 kaminari (RubyGems) Fixed in 1.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-11082
- 2026-10-03 Alias added: GHSA-r5jw-62xg-j433
References
Advisory 4
More kaminari vulnerabilities
- TI-2024-21844 Kaminari Insecure File Permissions Vulnerability CVSS 3.1MEDIUM 6.6
Sources
- CVE-2020-11082 · CVE Program
- CVE-2020-11082 · NVD
- FIRST EPSS
- GHSA-r5jw-62xg-j433 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences