MJML prior to 4.6.3 contains a path traversal vulnerability when processing the…
Priority LOW 37CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
MJML prior to 4.6.3 contains a path traversal vulnerability when processing the mj-include directive within an MJML document.
Why it matters now
EPSS 0.0266 85th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed mjml (npm): 4.6.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mjml (npm) | before 4.6.3 | 4.6.3 | Patch available | GHSA-4hch-r9xf-6vfr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mjml (npm) Vendor— Affected before 4.6.3 Fixed in 4.6.3 Patch available GHSA-4hch-r9xf-6vfr
Remediation
- Fix · GHSA-4hch-r9xf-6vfr mjml (npm) Fixed in 4.6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-12827
- 2026-10-03 Alias added: GHSA-4hch-r9xf-6vfr
References
Exploit 2
Advisory 4
Sources
- CVE-2020-12827 · CVE Program
- CVE-2020-12827 · NVD
- FIRST EPSS
- GHSA-4hch-r9xf-6vfr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences