Incorrect authorization in GitLab
Priority MEDIUM 40CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
An authorization issue relating to project maintainer impersonation was identified in GitLab EE 9.5 and later through 13.0.1 that could allow unauthorized users to impersonate as a maintainer to perform limited actions.
Why it matters now
EPSS 0.01017 63rd percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 12.9.8, 12.10.7, 13.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 9.5 to before 12.9.8; 12.10 to before 12.10.7; 13.0 to before 13.0.1 | 12.9.8, 12.10.7, 13.0.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 9.5 to before 12.9.8; 12.10 to before 12.10.7; 13.0 to before 13.0.1 Fixed in 12.9.8, 12.10.7, 13.0.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 9.5.0 to before 12.9.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 9.5.0 to before 12.9.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.10.0 to before 12.10.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.10.0 to before 12.10.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:13.0.0:*:*:*:community:*:*:* | 13.0.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:13.0.0:*:*:*:enterprise:*:*:* | 13.0.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 9.5.0 to before 12.9.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 9.5.0 to before 12.9.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.10.0 to before 12.10.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.10.0 to before 12.10.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:13.0.0:*:*:*:community:*:*:* Versions 13.0.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:13.0.0:*:*:*:enterprise:*:*:* Versions 13.0.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 12.9.8, 12.10.7, 13.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13263
- 2026-10-03 Alias added: GHSA-4h9q-f95v-pf5f
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2020-13263 · CVE Program
- CVE-2020-13263 · NVD
- FIRST EPSS
- GHSA-4h9q-f95v-pf5f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences