Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web script or HTML via the widgetId parameter to host-monitoring/src/toolbar.php. This vulnerability is fixed in versions 1.6.4, 18.10.3, 19.04.3, and 19.0.1 of the Centreon host-monitoring widget; 1.6.4, 18.10.5, 19.04.3, 19.10.2 of the Centreon service-monitoring widget; and 1.0.3, 18.10.1, 19.04.1, 19.10.1 of the Centreon tactical-overview widget.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:centreon:centreon_host-monitoring_widget:*:*:*:*:*:*:*:* | before 1.6.4; 18.10.0 to before 18.10.3; 19.0.0 to before 19.0.1; 19.04.0 to before 19.04.3 | Vulnerable | Centreon |
| cpe:2.3:a:centreon:centreon_tactical-overview_widget:*:*:*:*:*:*:*:* | before 1.0.3; 18.10.0 to before 18.10.1; 19.04.0 to before 19.04.1; 19.10.0 to before 19.10.1 | Vulnerable | Centreon |
| cpe:2.3:a:centreon:centreon_service-monitoring_widget:*:*:*:*:*:*:*:* | before 1.6.4; 18.10.0 to before 18.10.5; 19.04.0 to before 19.04.3; 19.10.0 to before 19.10.2 | Vulnerable | Centreon |
- cpe:2.3:a:centreon:centreon_host-monitoring_widget:*:*:*:*:*:*:*:* Versions before 1.6.4; 18.10.0 to before 18.10.3; 19.0.0 to before 19.0.1; 19.04.0 to before 19.04.3 Vulnerable ·Centreon
- cpe:2.3:a:centreon:centreon_tactical-overview_widget:*:*:*:*:*:*:*:* Versions before 1.0.3; 18.10.0 to before 18.10.1; 19.04.0 to before 19.04.1; 19.10.0 to before 19.10.1 Vulnerable ·Centreon
- cpe:2.3:a:centreon:centreon_service-monitoring_widget:*:*:*:*:*:*:*:* Versions before 1.6.4; 18.10.0 to before 18.10.5; 19.04.0 to before 19.04.3; 19.10.0 to before 19.10.2 Vulnerable ·Centreon
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13628
- 2026-10-03 Alias added: GHSA-6rgq-4749-9jm8
References
More Centreon Host-monitoring Widget vulnerabilities
- TI-2020-10692 Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web… CVSS 3.1MEDIUM 6.1
- TI-2020-08826 Cross-site scripting (XSS) vulnerability allows remote attackers to inject arbitrary web… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-13628 · CVE Program
- CVE-2020-13628 · NVD
- FIRST EPSS
- GHSA-6rgq-4749-9jm8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences