Cross-site request forgery in Drupal Entity Embed
Priority LOW 27CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-79.
Summary
The Entity Embed module provides a filter to allow embedding entities in content fields. In certain circumstances, the filter could allow an unprivileged user to inject HTML into a page when it is accessed by a trusted user with permission to embed entities. In some cases, this could lead to cross-site scripting.
Why it matters now
EPSS 0.00259 17th percentileScored 2026-11-07
Fix Fixed Entity Embed (Drupal): 8.x-1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Entity Embed | 8.x to before 8.x-1.2 | 8.x-1.2 | Patch available | CNA |
- Entity Embed VendorDrupal Affected 8.x to before 8.x-1.2 Fixed in 8.x-1.2 Patch available CNA
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:-:*:*:*:*:*:* | 8.x-1.0 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:alpha1:*:*:*:*:*:* | 8.x-1.0 alpha1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:alpha2:*:*:*:*:*:* | 8.x-1.0 alpha2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:alpha3:*:*:*:*:*:* | 8.x-1.0 alpha3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:beta1:*:*:*:*:*:* | 8.x-1.0 beta1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:beta2:*:*:*:*:*:* | 8.x-1.0 beta2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:beta3:*:*:*:*:*:* | 8.x-1.0 beta3 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:rc1:*:*:*:*:*:* | 8.x-1.0 rc1 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.0:rc2:*:*:*:*:*:* | 8.x-1.0 rc2 | Vulnerable | Drupal |
| cpe:2.3:a:drupal:entity_embed:8.x-1.1:*:*:*:*:*:*:* | 8.x-1.1 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:-:*:*:*:*:*:* Versions 8.x-1.0 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:alpha1:*:*:*:*:*:* Versions 8.x-1.0 alpha1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:alpha2:*:*:*:*:*:* Versions 8.x-1.0 alpha2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:alpha3:*:*:*:*:*:* Versions 8.x-1.0 alpha3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:beta1:*:*:*:*:*:* Versions 8.x-1.0 beta1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:beta2:*:*:*:*:*:* Versions 8.x-1.0 beta2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:beta3:*:*:*:*:*:* Versions 8.x-1.0 beta3 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:rc1:*:*:*:*:*:* Versions 8.x-1.0 rc1 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.0:rc2:*:*:*:*:*:* Versions 8.x-1.0 rc2 Vulnerable ·Drupal
- cpe:2.3:a:drupal:entity_embed:8.x-1.1:*:*:*:*:*:*:* Versions 8.x-1.1 Vulnerable ·Drupal
Remediation
- Fix · CNA Entity Embed (Drupal) Fixed in 8.x-1.2
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13673
- 2026-10-03 Alias added: GHSA-vhmw-c4p7-7jrc
References
Sources
- CVE-2020-13673 · CVE Program
- CVE-2020-13673 · NVD
- FIRST EPSS
- GHSA-vhmw-c4p7-7jrc · GitHub Advisory Database · CC BY 4.0
- CVE-2020-13673 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences