Read the docs
TI-2020-10968 Aliases CVE-2020-14001GHSA-mqm2-cgpr-p4m6

The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown…

Priority MEDIUM 49CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

The kramdown gem before 2.3.0 for Ruby processes the template option inside Kramdown documents by default, which allows unintended read access (such as template="/etc/passwd") or unintended embedded Ruby code execution (such as a string that begins with template="string://<%= `). NOTE: kramdown is used in Jekyll, GitLab Pages, GitHub Pages, and Thredded Forum.

Why it matters now

EPSS 0.0456 91st percentileScored 2026-11-07
Fix Fixed kramdown (RubyGems): 2.3.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—kramdown (RubyGems)before 2.3.02.3.0Patch availableGHSA-mqm2-cgpr-p4m6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • kramdown (RubyGems) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-mqm2-cgpr-p4m6

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:kramdown_project:kramdown:*:*:*:*:*:ruby:*:*before 2.3.0VulnerableKramdown Project
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:*31VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:*32VulnerableFedoraproject
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*20.04VulnerableCanonical
  • cpe:2.3:a:kramdown_project:kramdown:*:*:*:*:*:ruby:*:* Versions before 2.3.0 Vulnerable ·Kramdown Project
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* Versions 31 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
  • cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical

Remediation

  • Fix · GHSA-mqm2-cgpr-p4m6 kramdown (RubyGems) Fixed in 2.3.0 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-14001
  2. 2026-10-03 Alias added: GHSA-mqm2-cgpr-p4m6

References

Sources