CSRF vulnerability in save-server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
save-server (npm package) before version 1.05 is affected by a CSRF vulnerability, as there is no CSRF mitigation (Tokens etc.). The fix introduced in version version 1.05 unintentionally breaks uploading so version v1.0.7 is the fixed version. This is patched by implementing Double submit. The CSRF attack would require you to navigate to a malicious site while you have an active session with Save-Server (Session key stored in cookies). The malicious user would then be able to perform some actions, including uploading/deleting files and adding redirects. If you are logged in as root, this attack is significantly more severe. They can in addition create, delete and update users. If they updated the password of a user, that user's files would then be available. If the root password is updated, all files would be visible if they logged in with the new password. Note that due to the same origin policy malicious actors cannot view the gallery or the response of any of the methods, nor be sure they succeeded. This issue has been patched in version 1.0.7.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Neztore | save-server | before 1.0.5 | 1.0.5 | Patch available | CNA |
| — | save-server (npm) | before 1.0.7 | 1.0.7 | Patch available | GHSA-wwrj-35w6-77ff |
- save-server VendorNeztore Affected before 1.0.5 Fixed in 1.0.5 Patch available CNA
- save-server (npm) Vendor— Affected before 1.0.7 Fixed in 1.0.7 Patch available GHSA-wwrj-35w6-77ff
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:save-server_project:save-server:*:*:*:*:*:node.js:*:* | before 1.0.5 | Vulnerable | Save-server Project |
- cpe:2.3:a:save-server_project:save-server:*:*:*:*:*:node.js:*:* Versions before 1.0.5 Vulnerable ·Save-server Project
Remediation
- Fix · CNA save-server (Neztore) Fixed in 1.0.5
- Fix · GHSA-wwrj-35w6-77ff save-server (npm) Fixed in 1.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15135
- 2026-10-03 Alias added: GHSA-wwrj-35w6-77ff
References
Sources
- CVE-2020-15135 · CVE Program
- CVE-2020-15135 · NVD
- FIRST EPSS
- GHSA-wwrj-35w6-77ff · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences