Remote Code Execution in SyliusResourceBundle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-917.
Summary
In SyliusResourceBundle before versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4, rrequest parameters injected inside an expression evaluated by `symfony/expression-language` package haven't been sanitized properly. This allows the attacker to access any public service by manipulating that request parameter, allowing for Remote Code Execution. This issue has been patched for versions 1.3.14, 1.4.7, 1.5.2 and 1.6.4. Versions prior to 1.3 were not patched.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sylius | SyliusResourceBundle | before 1.3.14; 1.4.0 to before 1.4.7; 1.5.0 to before 1.5.2; 1.6.0 to before 1.6.4 | 1.3.14, 1.4.7, 1.5.2, 1.6.4 | Patch available | CNA |
| — | sylius/resource-bundle (Packagist) | 1.4.0 to before 1.4.7 | 1.4.7 | Patch available | GHSA-p4pj-9g59-4ppv |
| — | sylius/resource-bundle (Packagist) | 1.5.0 to before 1.5.2 | 1.5.2 | Patch available | GHSA-p4pj-9g59-4ppv |
| — | sylius/resource-bundle (Packagist) | 1.6.0 to before 1.6.4 | 1.6.4 | Patch available | GHSA-p4pj-9g59-4ppv |
| — | sylius/resource-bundle (Packagist) | 1.0.0 to before 1.3.14 | 1.3.14 | Patch available | GHSA-p4pj-9g59-4ppv |
- SyliusResourceBundle VendorSylius Affected before 1.3.14; 1.4.0 to before 1.4.7; 1.5.0 to before 1.5.2; 1.6.0 to before 1.6.4 Fixed in 1.3.14, 1.4.7, 1.5.2, 1.6.4 Patch available CNA
- sylius/resource-bundle (Packagist) Vendor— Affected 1.4.0 to before 1.4.7 Fixed in 1.4.7 Patch available GHSA-p4pj-9g59-4ppv
- sylius/resource-bundle (Packagist) Vendor— Affected 1.5.0 to before 1.5.2 Fixed in 1.5.2 Patch available GHSA-p4pj-9g59-4ppv
- sylius/resource-bundle (Packagist) Vendor— Affected 1.6.0 to before 1.6.4 Fixed in 1.6.4 Patch available GHSA-p4pj-9g59-4ppv
- sylius/resource-bundle (Packagist) Vendor— Affected 1.0.0 to before 1.3.14 Fixed in 1.3.14 Patch available GHSA-p4pj-9g59-4ppv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sylius:syliusresourcebundle:*:*:*:*:*:*:*:* | up to 1.3.13; 1.4.0 – 1.4.6; 1.5.0 – 1.5.1; 1.6.0 – 1.6.3 | Vulnerable | Sylius |
- cpe:2.3:a:sylius:syliusresourcebundle:*:*:*:*:*:*:*:* Versions up to 1.3.13; 1.4.0 – 1.4.6; 1.5.0 – 1.5.1; 1.6.0 – 1.6.3 Vulnerable ·Sylius
Remediation
- Fix · CNA SyliusResourceBundle (Sylius) Fixed in 1.3.14, 1.4.7, 1.5.2, 1.6.4
- Fix · GHSA-p4pj-9g59-4ppv sylius/resource-bundle (Packagist) Fixed in 1.4.7 Advisory →
- Fix · GHSA-p4pj-9g59-4ppv sylius/resource-bundle (Packagist) Fixed in 1.5.2 Advisory →
- Fix · GHSA-p4pj-9g59-4ppv sylius/resource-bundle (Packagist) Fixed in 1.6.4 Advisory →
- Fix · GHSA-p4pj-9g59-4ppv sylius/resource-bundle (Packagist) Fixed in 1.3.14 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15143
- 2026-10-03 Alias added: GHSA-p4pj-9g59-4ppv
References
More Syliusresourcebundle vulnerabilities
- TI-2020-11918 Remote Code Execution in SyliusResourceBundle CVSS 3.1CRITICAL 9.6
- TI-2020-04276 Ability to expose data in Sylius by using an unintended serialisation group CVSS 3.1MEDIUM 5.3
Sources
- CVE-2020-15143 · CVE Program
- CVE-2020-15143 · NVD
- FIRST EPSS
- GHSA-p4pj-9g59-4ppv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences