Remote Code Execution in paginator(hex)
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| duffelhq | paginator | before 1.0.0 | 1.0.0 | Patch available | CNA |
| — | paginator (Hex) | before 1.0.0 | 1.0.0 | Patch available | GHSA-w98m-2xqg-9cvj |
- paginator Vendorduffelhq Affected before 1.0.0 Fixed in 1.0.0 Patch available CNA
- paginator (Hex) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-w98m-2xqg-9cvj
Remediation
- Fix · CNA paginator (duffelhq) Fixed in 1.0.0
- Fix · GHSA-w98m-2xqg-9cvj paginator (Hex) Fixed in 1.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15150
- 2026-10-03 Alias added: GHSA-w98m-2xqg-9cvj
References
Advisory 3
Sources
- CVE-2020-15150 · CVE Program
- CVE-2020-15150 · NVD
- FIRST EPSS
- GHSA-w98m-2xqg-9cvj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences