Server-Side Request Forgery in ftp-srv
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
ftp-srv is an npm package which is a modern and extensible FTP server designed to be simple yet configurable. In ftp-srv before versions 2.19.6, 3.1.2, and 4.3.4 are vulnerable to Server-Side Request Forgery. The PORT command allows arbitrary IPs which can be used to cause the server to make a connection elsewhere. A possible workaround is blocking the PORT through the configuration. This issue is fixed in version2 2.19.6, 3.1.2, and 4.3.4. More information can be found on the linked advisory.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| autovance | ftp-srv | 1.0.0 to before 2.19.6; 3.0.0 to before 3.1.2; 4.0.0 to before 4.3.4 | 2.19.6, 3.1.2, 4.3.4 | Patch available | CNA |
| — | ftp-srv (npm) | 1.0.0 to before 2.19.6 | 2.19.6 | Patch available | GHSA-jw37-5gqr-cf9j |
| — | ftp-srv (npm) | 3.0.0 to before 3.1.2 | 3.1.2 | Patch available | GHSA-jw37-5gqr-cf9j |
| — | ftp-srv (npm) | 4.0.0 to before 4.3.4 | 4.3.4 | Patch available | GHSA-jw37-5gqr-cf9j |
- ftp-srv Vendorautovance Affected 1.0.0 to before 2.19.6; 3.0.0 to before 3.1.2; 4.0.0 to before 4.3.4 Fixed in 2.19.6, 3.1.2, 4.3.4 Patch available CNA
- ftp-srv (npm) Vendor— Affected 1.0.0 to before 2.19.6 Fixed in 2.19.6 Patch available GHSA-jw37-5gqr-cf9j
- ftp-srv (npm) Vendor— Affected 3.0.0 to before 3.1.2 Fixed in 3.1.2 Patch available GHSA-jw37-5gqr-cf9j
- ftp-srv (npm) Vendor— Affected 4.0.0 to before 4.3.4 Fixed in 4.3.4 Patch available GHSA-jw37-5gqr-cf9j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ftp-srv_project:ftp-srv:*:*:*:*:*:node.js:*:* | before 2.19.6; 3.0.0 to before 3.1.2; 4.0.0 to before 4.3.4 | Vulnerable | Ftp-srv Project |
- cpe:2.3:a:ftp-srv_project:ftp-srv:*:*:*:*:*:node.js:*:* Versions before 2.19.6; 3.0.0 to before 3.1.2; 4.0.0 to before 4.3.4 Vulnerable ·Ftp-srv Project
Remediation
- Fix · CNA ftp-srv (autovance) Fixed in 2.19.6, 3.1.2, 4.3.4
- Fix · GHSA-jw37-5gqr-cf9j ftp-srv (npm) Fixed in 2.19.6 Advisory →
- Fix · GHSA-jw37-5gqr-cf9j ftp-srv (npm) Fixed in 3.1.2 Advisory →
- Fix · GHSA-jw37-5gqr-cf9j ftp-srv (npm) Fixed in 4.3.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15152
- 2026-10-03 Alias added: GHSA-jw37-5gqr-cf9j
References
Patch 2
More Ftp-srv Project Ftp-srv vulnerabilities
- TI-2020-16120 File System Bounds Escape CVSS 3.1CRITICAL 9.6
Sources
- CVE-2020-15152 · CVE Program
- CVE-2020-15152 · NVD
- FIRST EPSS
- GHSA-jw37-5gqr-cf9j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences