XSS due to lack of CSRF validation for replying/publishing
Priority LOW 36CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
In nodebb-plugin-blog-comments before version 0.7.0, a logged in user is vulnerable to an XSS attack which could allow a third party to post on their behalf on the forum. This is due to lack of CSRF validation.
Why it matters now
EPSS 0.00612 49th percentileScored 2026-11-07
Fix Fixed nodebb-plugin-blog-comments (psychobunny): 0.7.0nodebb-plugin-blog-comments (npm): 0.7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| psychobunny | nodebb-plugin-blog-comments | before 0.7.0 | 0.7.0 | Patch available | CNA |
| — | nodebb-plugin-blog-comments (npm) | before 0.7.0 | 0.7.0 | Patch available | GHSA-43m5-c88r-cjvv |
- nodebb-plugin-blog-comments Vendorpsychobunny Affected before 0.7.0 Fixed in 0.7.0 Patch available CNA
- nodebb-plugin-blog-comments (npm) Vendor— Affected before 0.7.0 Fixed in 0.7.0 Patch available GHSA-43m5-c88r-cjvv
Remediation
- Fix · CNA nodebb-plugin-blog-comments (psychobunny) Fixed in 0.7.0
- Fix · GHSA-43m5-c88r-cjvv nodebb-plugin-blog-comments (npm) Fixed in 0.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15156
- 2026-10-03 Alias added: GHSA-43m5-c88r-cjvv
References
Sources
- CVE-2020-15156 · CVE Program
- CVE-2020-15156 · NVD
- FIRST EPSS
- GHSA-43m5-c88r-cjvv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences