XSS in Action View
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Rails | actionview | before 5.2.4.4; 6.0.0.0 to before 6.0.3.3 | 5.2.4.4, 6.0.3.3 | Patch available | CNA |
| — | actionview (RubyGems) | before 5.2.4.4 | 5.2.4.4 | Patch available | GHSA-cfjv-5498-mph5 |
| — | actionview (RubyGems) | 6.0.0.0 to before 6.0.3.3 | 6.0.3.3 | Patch available | GHSA-cfjv-5498-mph5 |
- actionview VendorRails Affected before 5.2.4.4; 6.0.0.0 to before 6.0.3.3 Fixed in 5.2.4.4, 6.0.3.3 Patch available CNA
- actionview (RubyGems) Vendor— Affected before 5.2.4.4 Fixed in 5.2.4.4 Patch available GHSA-cfjv-5498-mph5
- actionview (RubyGems) Vendor— Affected 6.0.0.0 to before 6.0.3.3 Fixed in 6.0.3.3 Patch available GHSA-cfjv-5498-mph5
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:action_view_project:action_view:*:*:*:*:*:ruby:*:* | before 5.2.4.4; 6.0.0.0 to before 6.0.3.3 | Vulnerable | Action View Project |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
- cpe:2.3:a:action_view_project:action_view:*:*:*:*:*:ruby:*:* Versions before 5.2.4.4; 6.0.0.0 to before 6.0.3.3 Vulnerable ·Action View Project
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA actionview (rails) Fixed in 5.2.4.4, 6.0.3.3
- Fix · GHSA-cfjv-5498-mph5 actionview (RubyGems) Fixed in 5.2.4.4 Advisory →
- Fix · GHSA-cfjv-5498-mph5 actionview (RubyGems) Fixed in 6.0.3.3 Advisory →
Red Hat 1 advisory
- RHSA-2021:1313 Released 2021-04-21 · Red Hat rating ModerateSatellite 6.9 Release
- Red Hat Satellite 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
- Red Hat Satellite Capsule 6.9 ansible-collection-redhat-satellite-2.0.1-1.el7sat, ansible-runner-1.4.6-1.el7ar, ansiblerole-foreman_scap_client-0.1.0-1.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.9 | Fixed | RHSA-2021:1313 |
| Red Hat Satellite Capsule 6.9 | Fixed | RHSA-2021:1313 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15169
- 2026-10-03 Alias added: GHSA-cfjv-5498-mph5
References
Advisory 4
Other 5
- https://github.com/rails/rails/commit/e663f084460ea56c55c3dc76f78c7caeddeeb02e
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionview/CVE-2020-15169.yml
- https://groups.google.com/g/rubyonrails-security/c/b-C9kSGXYrc
- https://lists.fedoraproject.org/archives/list/[email protected]/message/XJ7NUWXAEVRQCROIIBV4C6WXO6IR3KSB
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2026-47043 Action Pack: Possible arbitrary file read and remote code execution in Active Storage variant processing CVSS 4.0CRITICAL 9.5
- TI-2025-18040 Command injection in Rails activestorage CVSS 4.0CRITICAL 9.2
Sources
- CVE-2020-15169 · CVE Program
- CVE-2020-15169 · NVD
- FIRST EPSS
- GHSA-cfjv-5498-mph5 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-15169 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences