add-apt-repository print ASNI terminal codes
Priority LOW 25CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Versions of add-apt-repository before 0.98.9.2, 0.96.24.32.14, 0.96.20.10, and 0.92.37.8ubuntu0.1~esm1, printed a PPA (personal package archive) description to the terminal as-is, which allowed PPA owners to provide ANSI terminal escapes to modify terminal contents in unexpected ways.
Why it matters now
EPSS 0.00325 25th percentileScored 2026-11-07
Fix Fixed add-apt-repository (Canonical): 0.98.9.2, 0.96.24.32.14, 0.96.20.10 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | add-apt-repository | before 0.98.9.2; before 0.96.24.32.14; before 0.96.20.10; before 0.92.37.8ubuntu0.1~esm1 | 0.98.9.2, 0.96.24.32.14, 0.96.20.10, 0.92.37.8ubuntu0.1~esm1 | Patch available | CNA |
- add-apt-repository VendorCanonical Affected before 0.98.9.2; before 0.96.24.32.14; before 0.96.20.10; before 0.92.37.8ubuntu0.1~esm1 Fixed in 0.98.9.2, 0.96.24.32.14, 0.96.20.10, 0.92.37.8ubuntu0.1~esm1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:canonical:add-apt-repository:*:*:*:*:*:*:*:* | 0.92.37.0 to before 0.92.37.8ubuntu0.1\~esm1; 0.96.20.0 to before 0.96.20.10; 0.96.24.32.0 to before 0.96.24.32.14; 0.98.9.0 to before 0.98.9.2 | Vulnerable | Canonical |
- cpe:2.3:a:canonical:add-apt-repository:*:*:*:*:*:*:*:* Versions 0.92.37.0 to before 0.92.37.8ubuntu0.1\~esm1; 0.96.20.0 to before 0.96.20.10; 0.96.24.32.0 to before 0.96.24.32.14; 0.98.9.0 to before 0.98.9.2 Vulnerable ·Canonical
Remediation
- Fix · CNA add-apt-repository (Canonical) Fixed in 0.98.9.2, 0.96.24.32.14, 0.96.20.10, 0.92.37.8ubuntu0.1~esm1
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15709
- 2026-10-03 Alias added: GHSA-9gjg-6646-fqxh
References
Sources
- CVE-2020-15709 · CVE Program
- CVE-2020-15709 · NVD
- FIRST EPSS
- GHSA-9gjg-6646-fqxh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences