In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-295.
Summary
In Dogtag PKI through 10.8.3, the pki.client.PKIConnection class did not enable python-requests certificate validation. Since the verify parameter was hard-coded in all request functions, it was not possible to override the setting. As a result, tools making use of this class, such as the pki-server command, may have been vulnerable to Person-in-the-Middle attacks in certain non-localhost use cases. This is fixed in 10.9.0-b1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dogtagpki:dogtagpki:*:*:*:*:*:*:*:* | up to 10.8.3 | Vulnerable | Dogtag PKI |
- cpe:2.3:a:dogtagpki:dogtagpki:*:*:*:*:*:*:*:* Versions up to 10.8.3 Vulnerable ·Dogtag PKI
Remediation
Red Hat 1 advisory
- RHSA-2020:4847 Released 2020-11-04 · Red Hat rating Moderatepki-core:10.6 and pki-deps:10.6 security, bug fix, and enhancement update
- Red Hat Enterprise Linux AppStream (v. 8) apache-commons-collections-3.2.2-10.module+el8.1.0+3366+6dfb954c.noarch::pki-deps:10.6, apache-commons-collections-3.2.2-10.module+el8.1.0+3366+6dfb954c.src::pki-deps:10.6, apache-commons-lang-2.6-21.module+el8.1.0+3366+6dfb954c.noarch::pki-deps:10.6 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2020:4847 |
Timeline
- 2026-10-02 Threatist record created from CVE-2020-15720
- 2026-10-03 Alias added: GHSA-hpcm-hcj8-c96c
References
More Dogtag PKI Dogtagpki vulnerabilities
- TI-2022-02229 XML external entity injection in Dogtag PKI CVSS 3.1HIGH 7.5
- TI-2021-03479 Incorrect authorization in pki-core CVSS 3.1HIGH 8.1
- TI-2018-00999 Improper access control in [UNKNOWN] pki-core CVSS 3.0HIGH 8.1
- TI-2017-05178 Hard-coded credentials in Dogtag PKI pki-core CVSS 3.0HIGH 7.5
- TI-2021-02504 Cleartext storage of sensitive information in pki-server CVSS 3.1HIGH 7.8
- TI-2020-15729 Cross-site scripting in pki-core CVSS 3.1MEDIUM 6.1
Sources
- CVE-2020-15720 · CVE Program
- CVE-2020-15720 · NVD
- FIRST EPSS
- GHSA-hpcm-hcj8-c96c · GitHub Advisory Database · CC BY 4.0
- CVE-2020-15720 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences