Out-of-bounds write in Google Chrome
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
Heap buffer overflow in UI in Google Chrome on Windows prior to 86.0.4240.183 allowed a remote attacker who had compromised the renderer process to potentially perform a sandbox escape via a crafted HTML page.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | before 86.0.4240.183 | 86.0.4240.183 | Patch available | CNA |
- Chrome VendorGoogle Affected before 86.0.4240.183 Fixed in 86.0.4240.183 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 86.0.4240.183 | Vulnerable | |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* | 15.0 sp2 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Vulnerable | openSUSE |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 86.0.4240.183 Vulnerable ·Google
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:backports_sle:15.0:sp2:*:*:*:*:*:* Versions 15.0 sp2 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Vulnerable ·openSUSE
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Chrome (Google) Fixed in 86.0.4240.183
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Google Chrome — openSUSE-SU-2020:1829
39 records Highest priority Priority CRITICAL 2 CRITICAL, 24 MEDIUM, 13 LOW
Other records, highest priority first
- TI-2020-12611 Buffer overflow in Google ChromePriority CRITICAL 98
- TI-2020-12621 Out-of-bounds write in Google ChromePriority CRITICAL 97
- TI-2020-12584 Use after free in Google ChromePriority MEDIUM 43
- Advisory ·
Google Chrome — openSUSE-SU-2020:1831
7 records Highest priority Priority CRITICAL 1 CRITICAL, 5 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2020-12621 Out-of-bounds write in Google ChromePriority CRITICAL 97
- TI-2020-12618 Out-of-bounds write in Google ChromePriority MEDIUM 41
- TI-2020-12617 Improper handling of exceptional conditions in Google ChromePriority MEDIUM 41
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 6
Timeline
- 2026-10-02 Threatist record created from CVE-2020-16011
- 2026-10-03 Alias added: GHSA-p2gp-7c6p-m287
References
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2020-16011 · CVE Program
- CVE-2020-16011 · NVD
- FIRST EPSS
- GHSA-p2gp-7c6p-m287 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-16011 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences