Read the docs
TI-2020-12813 Aliases CVE-2020-16292GHSA-89jc-6wpm-mq54

A buffer overflow vulnerability in mj_raster_cmd() in contrib/japanese/gdevmjc.c of…

Priority LOW 29CWE-787Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 2 fixed, 3 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.

Summary

A buffer overflow vulnerability in mj_raster_cmd() in contrib/japanese/gdevmjc.c of Artifex Software GhostScript v9.50 allows a remote attacker to cause a denial of service via a crafted PDF file. This is fixed in v9.51.

Why it matters now

EPSS 0.01988 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial Red Hat: 1 advisoryRed Hat: 2 fixed, 3 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
  • — Vendor— Affected all versions Fixed in — No fix listed CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:*before 9.52VulnerableArtifex
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:*16.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*20.04VulnerableCanonical
  • cpe:2.3:a:artifex:ghostscript:*:*:*:*:*:*:*:* Versions before 9.52 Vulnerable ·Artifex
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:esm:*:*:* Versions 16.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical

Remediation

Red Hat 1 advisory

  • RHSA-2021:1852 Released 2021-05-18 · Red Hat rating Moderate
    ghostscript security, bug fix, and enhancement update
    • Red Hat CodeReady Linux Builder (v. 8) ghostscript-doc-9.27-1.el8, ghostscript-tools-dvipdf-9.27-1.el8, ghostscript-tools-fonts-9.27-1.el8 +2
    • Red Hat Enterprise Linux AppStream (v. 8) ghostscript-9.27-1.el8, ghostscript-x11-9.27-1.el8, libgs-9.27-1.el8

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 5AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Will not fix
Red Hat CodeReady Linux Builder (v. 8)Fixed RHSA-2021:1852
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2021:1852
Not affected: 1 product
  • Red Hat 3scale API Management Platform 2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-16292
  2. 2026-10-03 Alias added: GHSA-89jc-6wpm-mq54

References

Sources