jpv (aka Json Pattern Validator) before 2.2.2 does not properly validate input, as demonstrated by a corrupted array.
Priority MEDIUM 47CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
jpv (aka Json Pattern Validator) before 2.2.2 does not properly validate input, as demonstrated by a corrupted array.
Why it matters now
EPSS 0.02462 84th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed jpv (npm): 2.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | jpv (npm) | before 2.2.2 | 2.2.2 | Patch available | GHSA-vh6r-g38f-q3w8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- jpv (npm) Vendor— Affected before 2.2.2 Fixed in 2.2.2 Patch available GHSA-vh6r-g38f-q3w8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:json_pattern_validator_project:json_pattern_validator:*:*:*:*:*:node.js:*:* | before 2.2.2 | Vulnerable | Json Pattern Validator Project |
- cpe:2.3:a:json_pattern_validator_project:json_pattern_validator:*:*:*:*:*:node.js:*:* Versions before 2.2.2 Vulnerable ·Json Pattern Validator Project
Remediation
- Fix · GHSA-vh6r-g38f-q3w8 jpv (npm) Fixed in 2.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-17479
- 2026-10-03 Alias added: GHSA-vh6r-g38f-q3w8
References
More Json Pattern Validator Project Json Pattern Validator vulnerabilities
- TI-2019-14053 In jpv (aka Json Pattern Validator) before 2.1.1, compareCommon() can be bypassed because… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2020-17479 · CVE Program
- CVE-2020-17479 · NVD
- FIRST EPSS
- GHSA-vh6r-g38f-q3w8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences