Leo Editor v6.2.1 was discovered to contain a regular expression denial of service…
Priority LOW 35CWE-697Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
Leo Editor v6.2.1 was discovered to contain a regular expression denial of service (ReDoS) vulnerability in the component plugins/importers/dart.py.
Why it matters now
EPSS 0.01233 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed leo (PyPI): 6.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | leo (PyPI) | before 6.3 | 6.3 | Patch available | GHSA-x38q-xg2h-rxgx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- leo (PyPI) Vendor— Affected before 6.3 Fixed in 6.3 Patch available GHSA-x38q-xg2h-rxgx
Remediation
- Fix · GHSA-x38q-xg2h-rxgx leo (PyPI) Fixed in 6.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-23478
- 2026-10-03 Alias added: GHSA-x38q-xg2h-rxgx
References
Advisory 3
Sources
- CVE-2020-23478 · CVE Program
- CVE-2020-23478 · NVD
- FIRST EPSS
- GHSA-x38q-xg2h-rxgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences